summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-05-22 17:55:52 +0200
committerMarius Bakke <marius@gnu.org>2021-06-06 00:12:52 +0200
commit2d78486e609c0a50eb3bb9868c06b7655f6d82a0 (patch)
tree14e6d8423caaaecec9e961d00bba2ec6c978f50e
parente68df1408ade09d78235925b565b3b6116481c27 (diff)
downloadguix-2d78486e609c0a50eb3bb9868c06b7655f6d82a0.tar.gz
gnu: Add texlive-generic-intcalc.
* gnu/packages/tex.scm (texlive-generic-intcalc): New public variable.
-rw-r--r--gnu/packages/tex.scm15
1 files changed, 15 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 81d72ec62b..d860d99e85 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -7317,6 +7317,21 @@ the corresponding LaTeX commands; under Plain TeX they are available as
 complete implementations.")
     (license license:lppl1.3c+)))
 
+(define-public texlive-generic-intcalc
+  (package
+    (inherit (simple-texlive-package
+              "texlive-generic-intcalc"
+              '("/tex/generic/intcalc/")
+              (base32
+               "0llrnayqwdqxi91yh7panbbiljina3bynv2hxhi6sssaw3pyd92l")
+              #:trivial? #t))
+    (home-page "https://www.ctan.org/pkg/intcalc")
+    (synopsis "Expandable arithmetic operations with integers")
+    (description
+     "This package provides expandable arithmetic operations with integers,
+using the e-TeX extension @code{\\numexpr} if it is available.")
+    (license license:lppl1.3c+)))
+
 (define-public texlive-generic-listofitems
   (package
     (name "texlive-generic-listofitems")