summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-05-22 17:54:07 +0200
committerMarius Bakke <marius@gnu.org>2021-06-06 00:12:52 +0200
commit3e0dc201ec4256ba6b9d8a0e2cc93c81781ab748 (patch)
tree4bffe87ccc5afd21d6dd777c357b3e31e37eadb0
parent2d78486e609c0a50eb3bb9868c06b7655f6d82a0 (diff)
downloadguix-3e0dc201ec4256ba6b9d8a0e2cc93c81781ab748.tar.gz
gnu: Add texlive-generic-bigintcalc.
* gnu/packages/tex.scm (texlive-generic-bigintcalc): New public variable.
-rw-r--r--gnu/packages/tex.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index d860d99e85..f25dc4ce74 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -7300,6 +7300,24 @@ It makes use of e-TeX’s facilities if they are available.  The package may
 be used either with LaTeX or with plain TeX.")
     (license license:lppl1.3c+)))
 
+(define-public texlive-generic-bigintcalc
+  (package
+    (inherit (simple-texlive-package
+              "texlive-generic-bigintcalc"
+              '("/doc/latex/bigintcalc/README.md"
+                "/tex/generic/bigintcalc/")
+              (base32
+               "19grk4p1dh566hgpzhnjyjnrw57hpjijcpr7ci401n9jszcc1xkz")
+              #:trivial? #t))
+    (propagated-inputs
+     `(("texlive-latex-pdftexcmds" ,texlive-latex-pdftexcmds)))
+    (home-page "https://www.ctan.org/pkg/bigintcalc")
+    (synopsis "Integer calculations on very large numbers")
+    (description
+     "This package provides expandable arithmetic operations with big
+integers that can exceed TeX's number limits.")
+    (license license:lppl1.3c+)))
+
 (define-public texlive-generic-infwarerr
   (package
     (inherit (simple-texlive-package