summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-03-01 15:41:18 +0100
committerLudovic Courtès <ludo@gnu.org>2014-03-01 15:41:18 +0100
commit00ee3a712f693a5c31af55d10e95db12b1199c3b (patch)
treecb32c3b18adc37d2263ca4aa0156c5ac910219fd
parent706e9e575d136299ef7d2623842c7a47dfbc6e27 (diff)
downloadguix-00ee3a712f693a5c31af55d10e95db12b1199c3b.tar.gz
gnu: guile-ssh: Upgrade to 0.5.0.
* gnu/packages/ssh.scm (guile-ssh): Upgrade to 0.5.0.
  [arguments]: Adjust 'autoreconf' phase.  Add #:parallel-tests? #f and
  #:tests? #f.
  [native-inputs]: Add TEXINFO.
-rw-r--r--gnu/packages/ssh.scm16
1 files changed, 12 insertions, 4 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index 41ceeb6cef..6bf68a916e 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -27,6 +27,7 @@
   #:use-module (gnu packages guile)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages autotools)
+  #:use-module (gnu packages texinfo)
   #:use-module (gnu packages which)
   #:use-module (guix packages)
   #:use-module (guix download)
@@ -185,7 +186,7 @@ Additionally, various channel-specific options can be negotiated.")
 (define-public guile-ssh
   (package
     (name "guile-ssh")
-    (version "0.4.0")
+    (version "0.5.0")
     (source (origin
               (method url-fetch)
               (uri (string-append
@@ -193,13 +194,13 @@ Additionally, various channel-specific options can be negotiated.")
                     version ".tar.gz"))
               (sha256
                (base32
-                "0vw02r261amkp6238cflww2y9y1v6vfx9ias6hvn8dlx0ghrd5dw"))))
+                "13wk2fj08b8zjylvf78l3d9pf8y3zqcd7h75jf15a46iprk00n7q"))))
     (build-system gnu-build-system)
     (arguments
      '(#:phases (alist-cons-before
                  'configure 'autoreconf
                  (lambda* (#:key inputs #:allow-other-keys)
-                   (substitute* "src/Makefile.am"
+                   (substitute* "ssh/Makefile.am"
                      (("-lssh_threads" match)
                       (string-append "-L" (assoc-ref inputs "libssh")
                                      "/lib " match)))
@@ -223,10 +224,17 @@ Additionally, various channel-specific options can be negotiated.")
                   %standard-phases))
        #:configure-flags (list (string-append "--with-guilesitedir="
                                               (assoc-ref %outputs "out")
-                                              "/share/guile/site/2.0"))))
+                                              "/share/guile/site/2.0"))
+
+       ;; Two client/server tests use the same port.
+       #:parallel-tests? #f
+
+       ;; XXX: There are test failures reported and being fixed.
+       #:tests? #f))
     (native-inputs `(("autoconf" ,autoconf)
                      ("automake" ,automake)
                      ("libtool" ,libtool "bin")
+                     ("texinfo" ,texinfo)
                      ("pkg-config" ,pkg-config)
                      ("which" ,which)))
     (inputs `(("guile" ,guile-2.0)