summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-10-07 13:01:36 +0200
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-10-08 14:39:11 +0200
commit1285119bdedfd94c58e8938e465f626d998c4633 (patch)
tree7c77049efcf97637562c0b35294c2768b150863a
parentfd5b213302c446a4b2fa74f1df6215a073cc6d05 (diff)
downloadguix-1285119bdedfd94c58e8938e465f626d998c4633.tar.gz
gnu: Add python-joblib.
* gnu/packages/python.scm (python-joblib, python2-joblib): New
  variables.
-rw-r--r--gnu/packages/python.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 2c9772e933..5dda0b3429 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -2208,6 +2208,33 @@ written in pure Python.")
 (define-public python2-jinja2
   (package-with-python2 python-jinja2))
 
+(define-public python-joblib
+  (package
+    (name "python-joblib")
+    (version "0.9.0b4")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://pypi.python.org/packages/source/"
+                                  "j/joblib/joblib-" version ".tar.gz"))
+              (sha256
+               (base32
+                "1dvw3f8jgj6h0fxkghbgyclvdzc7l0ig7n0vis70awb5kczb9bs3"))))
+    (build-system python-build-system)
+    (native-inputs
+     `(("python-setuptools" ,python-setuptools)
+       ("python-nose"       ,python-nose)))
+    (home-page "http://pythonhosted.org/joblib/")
+    (synopsis "Using Python functions as pipeline jobs")
+    (description
+     "Joblib is a set of tools to provide lightweight pipelining in Python.
+In particular, joblib offers: transparent disk-caching of the output values
+and lazy re-evaluation (memoize pattern), easy simple parallel computing
+logging and tracing of the execution.")
+    (license bsd-3)))
+
+(define-public python2-joblib
+  (package-with-python2 python-joblib))
+
 (define-public python-docutils
   (package
     (name "python-docutils")