summary refs log tree commit diff
diff options
context:
space:
mode:
authorJohn Soo <jsoo1@asu.edu>2019-11-14 01:10:01 -0800
committerTimothy Sample <samplet@ngyro.com>2019-11-20 20:48:50 -0500
commit2ed8bd2d7df6235617e982b1fc01859c4dc657f6 (patch)
tree372a1e4348b2a46161382fd3b65bde7e243873d3
parentf2ed1e6d5240d25ed78fc61c2a2e0c574d689acf (diff)
downloadguix-2ed8bd2d7df6235617e982b1fc01859c4dc657f6.tar.gz
gnu: Add ghc-timezone-series.
* gnu/packages/haskell-xyz.scm (ghc-timezone-series): New variable.

Signed-off-by: Timothy Sample <samplet@ngyro.com>
-rw-r--r--gnu/packages/haskell-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index e21235163a..762acc3efc 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -11110,6 +11110,29 @@ timer manager.")
 used CPU time of monadic computation with an IO base.")
     (license license:bsd-3)))
 
+(define-public ghc-timezone-series
+  (package
+   (name "ghc-timezone-series")
+   (version "0.1.9")
+   (source
+    (origin
+     (method url-fetch)
+     (uri
+      (string-append
+       "mirror://hackage/package/timezone-series/timezone-series-"
+       version ".tar.gz"))
+     (sha256
+      (base32
+       "1blwgnyzqn917rgqkl4dncv9whv3xmk0lav040qq0214vksmvlz5"))))
+   (build-system haskell-build-system)
+   (home-page "https://archives.haskell.org/projects.haskell.org/time-ng/")
+   (synopsis "Enhanced timezone handling for Time")
+   (description
+    "This package endows @code{Data.Time}, from the time package, with several
+data types and functions for enhanced processing of timezones.  For one way to
+create timezone series, see the ghc-timezone-olson package.")
+   (license license:bsd-3)))
+
 (define-public ghc-tldr
   (package
     (name "ghc-tldr")