summary refs log tree commit diff
diff options
context:
space:
mode:
authorVagrant Cascadian <vagrant@reproducible-builds.org>2019-09-07 15:35:14 -0700
committerVagrant Cascadian <vagrant@debian.org>2019-09-07 20:28:18 -0700
commit3ec8c0ca942409da6ce06c38f6d8b6ccfc2a943a (patch)
tree512172060c1a450dae1608b63d702cd31284806f
parent9f74bd317f00c55ab1fa30683c1668a19bf17eab (diff)
downloadguix-3ec8c0ca942409da6ce06c38f6d8b6ccfc2a943a.tar.gz
gnu: diffoscope: Update to 123.
* gnu/packages/package-management (diffoscope): Update to 123.
  [arguments]: Update phase writable-test-data to include tests directory.
    Add phase remove-ocaml-test.
-rw-r--r--gnu/packages/package-management.scm18
1 files changed, 12 insertions, 6 deletions
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index 100c148fda..1cc2d3f6a0 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -546,7 +546,7 @@ transactions from C or Python.")
     (license license:gpl2+)))
 
 (define-public diffoscope
-  (let ((version "122"))
+  (let ((version "123"))
     (package
       (name "diffoscope")
       (version version)
@@ -558,7 +558,7 @@ transactions from C or Python.")
                 (file-name (git-file-name name version))
                 (sha256
                  (base32
-                  "1pwddknk8qyv88ba63why8vbnlc14b47434lv4ijx49m7ya3zfvg"))))
+                  "11bxms5rkhi0v4pxx29v4qgvhp3fmf0fkzci6gn5xcv4fl1zy4wj"))))
       (build-system python-build-system)
       (arguments
        `(#:phases (modify-phases %standard-phases
@@ -575,6 +575,13 @@ transactions from C or Python.")
                       (lambda _
                         (delete-file "tests/comparators/test_berkeley_db.py")
                         #t))
+                    ;; Test is dynamically generated and may have false
+                    ;; negatives with different ocaml versions.  Further
+                    ;; background in: https://bugs.debian.org/939386
+                    (add-after 'unpack 'remove-ocaml-test
+                      (lambda _
+                        (delete-file "tests/comparators/test_ocaml.py")
+                        #t))
                     (add-after 'unpack 'embed-tool-references
                       (lambda* (#:key inputs #:allow-other-keys)
                         (substitute* "diffoscope/comparators/utils/compare.py"
@@ -594,10 +601,9 @@ transactions from C or Python.")
                         #t))
                     (add-before 'check 'writable-test-data
                       (lambda _
-                        ;; tests/comparators/test_elf.py needs write access to
-                        ;; test data
-                        (make-file-writable
-                         "tests/data/ignore_readelf_errors_expected_diff")
+                        ;; tests may need needs write access to tests
+                        ;; directory
+                        (for-each make-file-writable (find-files "tests"))
                         #t))
                     (add-before 'check 'delete-failing-test
                       (lambda _