summary refs log tree commit diff
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2019-06-21 09:55:13 +0200
committerAndreas Enge <andreas@enge.fr>2019-06-21 09:55:13 +0200
commit468bfd13a05dec7b560ef50a70713226835facac (patch)
tree664a343e7110514b380ce54dac13854ed93a2f90
parente6eafd4277fe249dfc49e953c396cd4c93977088 (diff)
downloadguix-468bfd13a05dec7b560ef50a70713226835facac.tar.gz
gnu: ratpoints: Generate position-independent code.
* gnu/packages/algebra.scm (ratpoints): Add "CCFLAGS=-fPIC" to make flags.
-rw-r--r--gnu/packages/algebra.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 03b0e48671..edcfad1402 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -1353,7 +1353,8 @@ multiplication algorithm.")
     (arguments
      `(#:test-target "test"
        #:make-flags
-       (list (string-append "INSTALL_DIR=" (assoc-ref %outputs "out")))
+       (list (string-append "INSTALL_DIR=" (assoc-ref %outputs "out"))
+             "CCFLAGS=-fPIC")
        #:phases
        (modify-phases %standard-phases
          (delete 'configure)            ;no configure script