summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2019-09-10 22:34:22 +0900
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2019-09-11 18:10:20 +0900
commit4eb97c254effc95115d5e9da1b7083ecbc427a2f (patch)
tree312558de938d36973dc94be3001247a80f398ce9
parent1475094a457cd927e149d54ec9b8f59a8b05f0f2 (diff)
downloadguix-4eb97c254effc95115d5e9da1b7083ecbc427a2f.tar.gz
gnu: python-parso: Run the test suite.
* gnu/packages/python-xyz.scm (python-parso)[phases]: Replace the check phase.
-rw-r--r--gnu/packages/python-xyz.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ea183c0301..991082eed0 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -14755,6 +14755,10 @@ time-based (TOTP) passwords.")
     (native-inputs
      `(("python-pytest" ,python-pytest)))
     (build-system python-build-system)
+    (arguments
+     `(#:phases (modify-phases %standard-phases
+                  (replace 'check
+                    (lambda _ (invoke "pytest" "-vv"))))))
     (home-page "https://github.com/davidhalter/parso")
     (synopsis "Python Parser")
     (description "Parso is a Python parser that supports error recovery and