summary refs log tree commit diff
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2016-04-05 19:22:36 +0200
committerAndreas Enge <andreas@enge.fr>2016-04-05 19:22:36 +0200
commit53696f10c1cbcf2eace9bfb1837aa9b0860032db (patch)
tree2d3bfcc639611945da44c8cf16012c7e63f120d5
parentb146763a86812edc3de654403f70b8e699f2d090 (diff)
downloadguix-53696f10c1cbcf2eace9bfb1837aa9b0860032db.tar.gz
gnu: Add cddlib.
* gnu/packages/maths.scm (cddlib): New variable.
-rw-r--r--gnu/packages/maths.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 1d879713ac..adebf09a32 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -227,6 +227,31 @@ of linear equations, computes extreme rays of polyhedral cones, solves
 integer programming problems and computes Markov bases for statistics.")
     (license license:gpl2+)))
 
+(define-public cddlib
+  (package
+    (name "cddlib")
+    (version "0.94h")
+    (source
+     (origin
+      (method url-fetch)
+      (uri (string-append "ftp://ftp.ifor.math.ethz.ch/pub/fukuda/cdd/cddlib-"
+                          (string-delete #\. version) ".tar.gz"))
+      (sha256
+       (base32
+        "1dasasscwfg793q8fwzgwf64xwj7w62yfvszpr8x8g38jka08vgy"))))
+    (build-system gnu-build-system)
+    (inputs
+     `(("gmp" ,gmp)))
+    (home-page "https://www.inf.ethz.ch/personal/fukudak/cdd_home/index.html")
+    (synopsis "Library for convex hulls and extreme rays of polyhedra")
+    (description
+     "The C-library cddlib implements the Double Description Method of
+Motzkin et al. for generating all vertices (i.e. extreme points) and extreme
+rays of a general convex polyhedron given by a system of linear inequalities
+in arbitrary dimension.  It can also be used for the converse operation of
+computing convex hulls.")
+    (license license:gpl2+)))
+
 (define-public arpack-ng
   (package
     (name "arpack-ng")