summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2018-12-12 12:22:29 +0200
committerEfraim Flashner <efraim@flashner.co.il>2018-12-12 12:23:07 +0200
commit56a88478b908110b513f8c9c767c32facf1b202d (patch)
treee27638542ff0d41233ac769f43093cc324e1cf36
parent83a40cbfd6720306ea4ac87cb028ebfe70611365 (diff)
downloadguix-56a88478b908110b513f8c9c767c32facf1b202d.tar.gz
gnu: gdk-pixbuf: Only extend the test timeout on some architectures.
* gnu/packages/gtk.scm (gdk-pixbuf)[arguments]: Remove substitution
extending test timeout to 1800 seconds. Replace check on armhf-linux
and aarch64-linux to use 'timeout-multiplier' on the test suite.
-rw-r--r--gnu/packages/gtk.scm17
1 files changed, 11 insertions, 6 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 0f527e0e98..9f51f0d54a 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -76,7 +76,9 @@
   #:use-module (gnu packages cups)
   #:use-module (gnu packages xml)
   #:use-module (gnu packages xorg)
-  #:use-module (gnu packages xdisorg))
+  #:use-module (gnu packages xdisorg)
+  #:use-module (srfi srfi-1)
+  #:use-module (srfi srfi-26))
 
 (define-public atk
   (package
@@ -471,12 +473,15 @@ highlighting and other features typical of a source code editor.")
              ;; ERROR:pixbuf-jpeg.c:74:test_type9_rotation_exif_tag:
              ;; assertion failed (error == NULL): Data differ
              ;; (gdk-pixbuf-error-quark, 0)
-             ((".*'pixbuf-jpeg'.*") "")
-             ;; Extend the timeout of the test suite.
-             ;; TODO: Check upstreaming effort:
-             ;; https://gitlab.gnome.org/GNOME/gdk-pixbuf/merge_requests/21
-             (("300") "1800"))
+             ((".*'pixbuf-jpeg'.*") ""))
            #t))
+        ;; The slow tests take longer than the specified timeout.
+        ,@(if (any (cute string=? <> (%current-system))
+                   '("armhf-linux" "aarch64-linux"))
+            '((replace 'check
+              (lambda _
+                (invoke "meson" "test" "--timeout-multiplier" "5"))))
+            '())
         (add-before 'configure 'aid-install-script
           (lambda* (#:key outputs #:allow-other-keys)
             ;; "build-aux/post-install.sh" invokes `gdk-pixbuf-query-loaders`