summary refs log tree commit diff
diff options
context:
space:
mode:
authorSteve Sprang <scs@stevesprang.com>2015-08-16 20:43:07 -0700
committerRicardo Wurmus <rekado@elephly.net>2015-08-20 08:28:47 +0200
commit6ef9edbff33fb195d38f879cab66ee98c3738efe (patch)
tree837af50c36e3053e6e2f94cc148e1bd59c89140c
parentde63b20ed1753221161c4ec7b1e032d2141cc38c (diff)
downloadguix-6ef9edbff33fb195d38f879cab66ee98c3738efe.tar.gz
gnu: Add figlet.
* gnu/packages/figlet.scm: New file.
* gnu-system.am (GNU_SYSTEM_MODULES): Add it.
-rw-r--r--gnu-system.am1
-rw-r--r--gnu/packages/figlet.scm46
2 files changed, 47 insertions, 0 deletions
diff --git a/gnu-system.am b/gnu-system.am
index aca0144abd..1e58777d7d 100644
--- a/gnu-system.am
+++ b/gnu-system.am
@@ -96,6 +96,7 @@ GNU_SYSTEM_MODULES =				\
   gnu/packages/enlightenment.scm		\
   gnu/packages/fcitx.scm			\
   gnu/packages/feh.scm                          \
+  gnu/packages/figlet.scm			\
   gnu/packages/file.scm				\
   gnu/packages/firmware.scm			\
   gnu/packages/fish.scm				\
diff --git a/gnu/packages/figlet.scm b/gnu/packages/figlet.scm
new file mode 100644
index 0000000000..5e19dafee3
--- /dev/null
+++ b/gnu/packages/figlet.scm
@@ -0,0 +1,46 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2015 Steve Sprang <scs@stevesprang.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages figlet)
+  #:use-module ((guix licenses) #:prefix license:)
+  #:use-module (guix packages)
+  #:use-module (guix download)
+  #:use-module (guix build-system gnu))
+
+(define-public figlet
+  (package
+    (name "figlet")
+    (version "2.2.5")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "ftp://ftp.figlet.org/pub/figlet/program"
+                           "/unix/figlet-" version ".tar.gz"))
+       (sha256
+        (base32 "0za1ax15x7myjl8jz271ybly8ln9kb9zhm1gf6rdlxzhs07w925z"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases (delete 'configure))
+       #:make-flags
+       (list (string-append "prefix=" %output))))
+    (home-page "http://www.figlet.org/")
+    (synopsis "Make large letterforms out of ordinary screen characters")
+    (description "FIGlet is a program for making large ASCII art letterforms
+out of ordinary screen characters.")
+    (license license:bsd-3)))