summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-03-10 23:58:40 +0100
committerLudovic Courtès <ludo@gnu.org>2014-03-10 23:58:40 +0100
commit6f58d582432fe46c163f61ddf8f653584f4f7be8 (patch)
tree3ab9b1314089786ac9c76cedc5449151e990636c
parentc9c88118a12b0e22b7369b1dc6b0e2f9db894986 (diff)
downloadguix-6f58d582432fe46c163f61ddf8f653584f4f7be8.tar.gz
More /gnu/store replacements.
* gnu/packages/gcc.scm (gcc-4.7): Change /nix/store in comment.
* gnu/system/vm.scm (operating-system-default-contents):
  Use (%store-prefix) instead of "/nix/store".
* guix/derivations.scm (derivation-path->output-path,
  derivation-path->output-paths): Change to /gnu/store in docstring.
-rw-r--r--gnu/packages/gcc.scm4
-rw-r--r--gnu/system/vm.scm4
-rw-r--r--guix/derivations.scm4
3 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index 279cc8d950..cb7817c084 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -1,5 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013, 2014 Ludovic Courtès <ludo@gnu.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -186,7 +186,7 @@ where the OS part is overloaded to denote a specific ABI---into GCC
            'configure 'post-configure
            (lambda _
              ;; Don't store configure flags, to avoid retaining references to
-             ;; build-time dependencies---e.g., `--with-ppl=/nix/store/xxx'.
+             ;; build-time dependencies---e.g., `--with-ppl=/gnu/store/xxx'.
              (substitute* "Makefile"
                (("^TOPLEVEL_CONFIGURE_ARGUMENTS=(.*)$" _ rest)
                 "TOPLEVEL_CONFIGURE_ARGUMENTS=\n")))
diff --git a/gnu/system/vm.scm b/gnu/system/vm.scm
index b6a777353f..a23289a30b 100644
--- a/gnu/system/vm.scm
+++ b/gnu/system/vm.scm
@@ -373,7 +373,7 @@ such as /etc files."
                                      ;; (not 'futime'), so the timestamp of
                                      ;; symlinks cannot be changed, and there
                                      ;; are symlinks here pointing to
-                                     ;; /nix/store, which is the host,
+                                     ;; /gnu/store, which is the host,
                                      ;; read-only store.
                                      (unless (eq? (stat:type s) 'symlink)
                                        (utime file 0 0 0 0))))
@@ -448,7 +448,7 @@ basic contents of the root file system of OS."
                        (os-dir -> (derivation->output-path os-drv))
                        (build-gid (operating-system-build-gid os))
                        (profile   (operating-system-profile-directory os)))
-    (return `((directory "/nix/store" 0 ,(or build-gid 0))
+    (return `((directory ,(%store-prefix) 0 ,(or build-gid 0))
               (directory "/etc")
               (directory "/var/log")                     ; for dmd
               (directory "/var/run/nscd")
diff --git a/guix/derivations.scm b/guix/derivations.scm
index 82a0173232..f26075f84a 100644
--- a/guix/derivations.scm
+++ b/guix/derivations.scm
@@ -451,13 +451,13 @@ that form."
   ;; This procedure is called frequently, so memoize it.
   (memoize
    (lambda* (path #:optional (output "out"))
-     "Read the derivation from PATH (`/nix/store/xxx.drv'), and return the store
+     "Read the derivation from PATH (`/gnu/store/xxx.drv'), and return the store
 path of its output OUTPUT."
      (derivation->output-path (call-with-input-file path read-derivation)
                               output))))
 
 (define (derivation-path->output-paths path)
-  "Read the derivation from PATH (`/nix/store/xxx.drv'), and return the
+  "Read the derivation from PATH (`/gnu/store/xxx.drv'), and return the
 list of name/path pairs of its outputs."
   (derivation->output-paths (call-with-input-file path read-derivation)))