summary refs log tree commit diff
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2016-04-04 20:04:48 +0200
committerAlex Kost <alezost@gmail.com>2016-04-05 11:29:32 +0300
commit9b36e256076a4c28051d0e0735e0f990c2dc0834 (patch)
tree288184a15dc2a03d2396237a42a2bf34efcef6f9
parent17130e3919326937b244bb1d3dfec59e48cc1c92 (diff)
downloadguix-9b36e256076a4c28051d0e0735e0f990c2dc0834.tar.gz
gnu: vcftools: Update to 0.1.14.
* gnu/packages/bioinformatics.scm (vcftools): Update to 0.1.14.
[arguments]: Do not modify phases as it is not needed anymore.
[native-inputs]: Add 'pkg-config'.
[home-page]: Update to new location.

Signed-off-by: Alex Kost <alezost@gmail.com>
-rw-r--r--gnu/packages/bioinformatics.scm23
1 files changed, 9 insertions, 14 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 250deb9b6b..0afc0a6979 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -3692,15 +3692,15 @@ Cuffdiff or Ballgown programs.")
 (define-public vcftools
   (package
     (name "vcftools")
-    (version "0.1.12b")
+    (version "0.1.14")
     (source (origin
               (method url-fetch)
               (uri (string-append
-                    "mirror://sourceforge/vcftools/vcftools_"
-                     version ".tar.gz"))
+                    "https://github.com/vcftools/vcftools/releases/download/v"
+                    version "/vcftools-" version ".tar.gz"))
               (sha256
                (base32
-                "148al9h7f8g8my2qdnpax51kdd2yjrivlx6frvakf4lz5r8j88wx"))))
+                "10l5c07z9p4i9pr4gl54b2c9h6ndhqlbq1rashg2zcgwkbfrkmvn"))))
     (build-system gnu-build-system)
     (arguments
      `(#:tests? #f ; no "check" target
@@ -3708,18 +3708,13 @@ Cuffdiff or Ballgown programs.")
                      "CFLAGS=-O2" ; override "-m64" flag
                      (string-append "PREFIX=" (assoc-ref %outputs "out"))
                      (string-append "MANDIR=" (assoc-ref %outputs "out")
-                                    "/share/man/man1"))
-       #:phases
-       (alist-cons-after
-        'unpack 'patch-manpage-install
-        (lambda _
-          (substitute* "Makefile"
-            (("cp \\$\\{PREFIX\\}/cpp/vcftools.1") "cp ./cpp/vcftools.1")))
-        (alist-delete 'configure %standard-phases))))
+                                    "/share/man/man1"))))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
     (inputs
      `(("perl" ,perl)
        ("zlib" ,zlib)))
-    (home-page "http://vcftools.sourceforge.net/")
+    (home-page "https://vcftools.github.io/")
     (synopsis "Tools for working with VCF files")
     (description
      "VCFtools is a program package designed for working with VCF files, such
@@ -3727,7 +3722,7 @@ as those generated by the 1000 Genomes Project.  The aim of VCFtools is to
 provide easily accessible methods for working with complex genetic variation
 data in the form of VCF files.")
     ;; The license is declared as LGPLv3 in the README and
-    ;; at http://vcftools.sourceforge.net/license.html
+    ;; at https://vcftools.github.io/license.html
     (license license:lgpl3)))
 
 (define-public vsearch