summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-09-10 23:34:13 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-09-11 00:33:50 +0200
commitabab956bfc52fc057667cd55fd776e75916e9eea (patch)
tree311383f3e01a2b3af5326fdd7b16853e43f34faa
parent886534b4e0ff471e951c33dd3aea4dfbd11e9420 (diff)
downloadguix-abab956bfc52fc057667cd55fd776e75916e9eea.tar.gz
gnu: umockdev: Update to 0.13.2.
* gnu/packages/check.scm (umockdev): Update to 0.13.2.
-rw-r--r--gnu/packages/check.scm12
1 files changed, 7 insertions, 5 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 085538b2de..374a4d35fa 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -2243,7 +2243,7 @@ provides a simple way to achieve this.")
 (define-public umockdev
   (package
     (name "umockdev")
-    (version "0.12.1")
+    (version "0.13.2")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://github.com/martinpitt/umockdev/"
@@ -2251,7 +2251,7 @@ provides a simple way to achieve this.")
                                   "umockdev-" version ".tar.xz"))
               (sha256
                (base32
-                "1hx5jm9afng6hw9wyp524z8nwdp6w053pca0w2c0gqpgrmvjxvd2"))))
+                "095v3abc321s584sga04y16lcmdzsdi88h24wcrm78v7vq484g74"))))
     (build-system gnu-build-system)
     (arguments
      `(#:phases
@@ -2264,10 +2264,12 @@ provides a simple way to achieve this.")
              #t)))))
     (native-inputs
      `(("vala" ,vala)
-       ("python" ,python)               ; for tests
-       ("which" ,which)                 ; for tests
        ("gtk-doc" ,gtk-doc)
-       ("pkg-config" ,pkg-config)))
+       ("pkg-config" ,pkg-config)
+
+       ;; For tests.
+       ("python" ,python)
+       ("which" ,which)))
     (inputs
      `(("glib" ,glib)
        ("eudev" ,eudev)