summary refs log tree commit diff
diff options
context:
space:
mode:
authorVasile Dumitrascu <va511e@yahoo.com>2017-03-28 21:58:42 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-03-29 03:05:40 +0200
commitb125649a5945f54b2af4f2cf8919580d1db07cc6 (patch)
tree9670d9f9fe67c72b164b3a0ea8adcf12fe21ed37
parent3ee9355e2fd2d0fcee1076ca1160ba5881b73da8 (diff)
downloadguix-b125649a5945f54b2af4f2cf8919580d1db07cc6.tar.gz
gnu: emacs-monroe: Don't use MELPA archive.
* gnu/packages/emacs.scm (emacs-monroe)[version]: Change to 0.3.1.
[source]: Use github instead of melpa. Add (file-name).
[home-page]: Use HTTPS.

Signed-off-by: Marius Bakke <mbakke@fastmail.com>
-rw-r--r--gnu/packages/emacs.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index fbd5b08059..bf6a84b0a5 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -3427,17 +3427,18 @@ used for reverse direction.")
 (define-public emacs-monroe
   (package
     (name "emacs-monroe")
-    (version "20170220.540")
+    (version "0.3.1")
     (source
       (origin
         (method url-fetch)
-        (uri (string-append "http://melpa.org/packages/monroe-"
-                            version ".el"))
+        (uri (string-append "https://github.com/sanel/monroe/archive/"
+                            version ".tar.gz"))
+        (file-name (string-append name "-" version ".tar.gz"))
         (sha256
           (base32
-            "06p0qdhg4arwij1qpiiiwsd0m1bbl1qwd20ij2bmhryrvrcpswq3"))))
+            "0icdx8shkd951phlnmcq1vqaxp1l667q5rjscskc5r22aylakh4w"))))
     (build-system emacs-build-system)
-    (home-page "http://www.github.com/sanel/monroe")
+    (home-page "https://github.com/sanel/monroe")
     (synopsis "Clojure nREPL client for Emacs")
     (description
       "Monroe is a nREPL client for Emacs, focused on simplicity and easy