summary refs log tree commit diff
diff options
context:
space:
mode:
authorVincent Legoll <vincent.legoll@gmail.com>2020-04-11 20:23:42 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-04-12 15:22:32 +0200
commitc492b23fb1c33e9f5d1c1f07e4bb3d364fe36df8 (patch)
treef77a3fcab5885a12f1adfce11a3da807596590e1
parentdb79c15073c5b672fa7233fddfb44a61678e83bf (diff)
downloadguix-c492b23fb1c33e9f5d1c1f07e4bb3d364fe36df8.tar.gz
gnu: openttd-opengfx: Update to 0.6.0.
* gnu/packages/games.scm (openttd-opengfx)[version]: Update to 0.6.0.
[source]: Change uri to cdn.openttd.org.
[native-inputs]: Add which.
-rw-r--r--gnu/packages/games.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 31e1936795..5543e46ac8 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -3034,15 +3034,15 @@ engine.  When you start it you will be prompted to download a graphics set.")
 (define openttd-opengfx
   (package
     (name "openttd-opengfx")
-    (version "0.5.5")
+    (version "0.6.0")
     (source
      (origin
        (method url-fetch)
-       (uri (string-append "http://binaries.openttd.org/extra/opengfx/"
+       (uri (string-append "https://cdn.openttd.org/opengfx-releases/"
                            version "/opengfx-" version "-source.tar.xz"))
        (sha256
         (base32
-         "009fa1bdin1bk0ynzhzc30hzkmmwzmwkk6j591ax3f6w75l28n49"))))
+         "0qxc6gl2gxcrn1np88dnjgbaaakkkx96b13rcmy1spryc8c09hyr"))))
     (build-system gnu-build-system)
     (arguments
      '(#:make-flags (list "CC=gcc"
@@ -3072,6 +3072,7 @@ engine.  When you start it you will be prompted to download a graphics set.")
                      ("gimp" ,gimp)
                      ("grfcodec" ,grfcodec)
                      ("nml" ,nml)
+                     ("which" ,which)
                      ("python" ,python-2)))
     (home-page "http://dev.openttdcoop.org/projects/opengfx")
     (synopsis "Base graphics set for OpenTTD")