summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-12-08 22:52:28 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-12-08 22:52:28 +0100
commitd871e29ada230093588b7894b76aa71fb7990c60 (patch)
treee1c632910f072b425cf0b9a812ebc703b3c0a8b5
parent5763243c4f5186e9da58ef79dc9c8b589e125d2d (diff)
downloadguix-d871e29ada230093588b7894b76aa71fb7990c60.tar.gz
gnu: supercollider: Fix build.
Fixes <https://bugs.gnu.org/33674>.

* gnu/packages/audio.scm (supercollider)[arguments]: Add phase to fix build
with Boost 1.68.
[inputs]: Replace boost with boost-cxx14.
-rw-r--r--gnu/packages/audio.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index cb91de49cd..345140aba1 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -2202,6 +2202,12 @@ background file post-processing.")
                   (ice-9 ftw))
        #:phases
        (modify-phases %standard-phases
+         (add-after 'unpack 'fix-build-with-boost-1.68
+           (lambda _
+             (substitute* "server/supernova/utilities/time_tag.hpp"
+               (("(time_duration offset = .+ microseconds\\().*" _ m)
+                (string-append m "static_cast<long>(get_nanoseconds()/1000));\n")))
+             #t))
          (add-after 'unpack 'rm-bundled-libs
            (lambda _
              ;; The build system doesn't allow us to unbundle the following
@@ -2266,7 +2272,7 @@ external_libraries/yaml-cpp/include)"))
        ("eudev" ,eudev)                 ;for user interactions with devices
        ("avahi" ,avahi)                 ;zeroconf service discovery support
        ("icu4c" ,icu4c)
-       ("boost" ,boost)
+       ("boost" ,boost-cxx14)
        ("boost-sync" ,boost-sync)
        ("yaml-cpp" ,yaml-cpp)))
     (home-page "https://github.com/supercollider/supercollider")