summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2018-10-17 10:54:58 +0300
committerEfraim Flashner <efraim@flashner.co.il>2018-10-17 10:55:26 +0300
commitda39ff58987d7ed082233ab9ac3ae8d6d0f50b5d (patch)
tree8bdeddfd4e71bdbfcae8e7e65189e84f79ea281c
parent56112a577ce445646aaddb9701f4af6b5626fb70 (diff)
downloadguix-da39ff58987d7ed082233ab9ac3ae8d6d0f50b5d.tar.gz
gnu: boost-for-mysql: Remove unnecessary phase.
* gnu/packages/boost.scm (boost-for-mysql)[arguments]: Remove custom
'provide-libboost_python phase. Add removed '/bin/sh' substitution.
-rw-r--r--gnu/packages/boost.scm11
1 files changed, 11 insertions, 0 deletions
diff --git a/gnu/packages/boost.scm b/gnu/packages/boost.scm
index d1b359b2cb..897987f71c 100644
--- a/gnu/packages/boost.scm
+++ b/gnu/packages/boost.scm
@@ -9,6 +9,7 @@
 ;;; Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
 ;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2018 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2018 Efraim Flashner <efraim@flashner.co.il>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -27,6 +28,7 @@
 
 (define-module (gnu packages boost)
   #:use-module ((guix licenses) #:prefix license:)
+  #:use-module (guix utils)
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix git-download)
@@ -134,6 +136,15 @@ across a broad spectrum of applications.")
               (sha256
                (base32
                 "1jj1aai5rdmd72g90a3pd8sw9vi32zad46xv5av8fhnr48ir6ykj"))))
+    (arguments (substitute-keyword-arguments (package-arguments boost)
+      ((#:phases phases)
+       `(modify-phases ,phases
+          ;; This was removed after boost-1.67.
+          (add-before 'configure 'more-bin-sh-patching
+            (lambda _
+              (substitute* "tools/build/doc/bjam.qbk"
+                (("/bin/sh") (which "sh")))))
+          (delete 'provide-libboost_python)))))
     (properties '((hidden? . #t)))))
 
 (define-public boost-sync