summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-04-02 16:11:12 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-04-02 16:11:12 +0200
commitdc112a0fe2e0ffe00276cdd61167084ec1ff0849 (patch)
tree725e4fc406cb18fa0d8206d6f23147dc00a7d9c8
parent82cc11745008a6c15c64c31bbd8b8b47f5cb8171 (diff)
downloadguix-dc112a0fe2e0ffe00276cdd61167084ec1ff0849.tar.gz
gnu: Add python-loompy-for-pigx-scrnaseq.
* gnu/packages/bioinformatics.scm (python-loompy-for-pigx-scrnaseq): New variable.
-rw-r--r--gnu/packages/bioinformatics.scm17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index e9b866f6d7..c37fb6fe42 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -12038,6 +12038,23 @@ graphs.  This library makes it easy to work with @file{.loom} files for
 single-cell RNA-seq data.")
     (license license:bsd-3)))
 
+;; pigx-scrnaseq does not work with the latest version of loompy.
+(define-public python-loompy-for-pigx-scrnaseq
+  (package (inherit python-loompy)
+    (name "python-loompy")
+    (version "2.0.3")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/linnarsson-lab/loompy.git")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0pjyl532pl8sbv71yci6h0agchn0naw2qjcwj50n6afrsahbsag3"))))
+    ;; There are none.
+    (arguments '(#:tests? #f))))
+
 ;; We cannot use the latest commit because it requires Java 9.
 (define-public java-forester
   (let ((commit "86b07efe302d5094b42deed9260f719a4c4ac2e6")