summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-20 11:09:14 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-20 11:17:48 +0200
commit00229c844c9044b8eb9f2368841116e4932f5fc5 (patch)
tree16acfbd725f12a86609aefed2a8858d092e3b375
parent31cb95d2035f9b5a80531dea67b0aae9f9c13d29 (diff)
downloadguix-00229c844c9044b8eb9f2368841116e4932f5fc5.tar.gz
gnu: Add texlive-xii.
* gnu/packages/tex.scm (texlive-xii): New variable.
-rw-r--r--gnu/packages/tex.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index ce16ea49ac..2717f7b2c2 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3981,6 +3981,24 @@ a size-change macro.  Note that @file{10point.tex} is by convention called by
 one of the other files, so that there's always a way back.")
     (license license:public-domain)))
 
+(define-public texlive-xii
+  (package
+    (name "texlive-xii")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/plain/xii/")
+             (base32
+              "19jhzv5hqzj59wrfcr1dsj6z56qfckax694idgf8arri5lnbkdd8")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/xii")
+    (synopsis "Christmas silliness (English)")
+    (description
+     "This is the plain TeX file @file{xii.tex}.  Call @samp{pdftex xii.tex}
+to produce a (perhaps) surprising typeset document.")
+    (license license:lppl)))
+
 (define-public texlive-lcdftypetools
   (package
     (name "texlive-lcdftypetools")