summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-08 23:15:55 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:12:56 +0200
commit09283bb0ab560ae50b33a504368d8769a7d04a50 (patch)
treea84694d957f139f4aaaaa0ac17237a8a30155273
parent0224a8f400278c0afafc0aa4d45ee5ee261df59b (diff)
downloadguix-09283bb0ab560ae50b33a504368d8769a7d04a50.tar.gz
gnu: Add texlive-luahbtex.
* gnu/packages/tex.scm (texlive-luahbtex): New variable.
-rw-r--r--gnu/packages/tex.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 21593d190e..effec09698 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3492,6 +3492,38 @@ upgrade smoothly to the new support structure.")
      "The package provides emulation of pdfTeX primitives for LuaTeX v0.85+.")
     (license license:lppl1.3+)))
 
+(define-public texlive-luahbtex
+  (package
+    (name "texlive-luahbtex")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/man/man1/luahbtex.1"
+                   "doc/man/man1/luahbtex.man1.pdf")
+             (base32
+              "0w4hfjmjgiw42bpz1b59cla8v4s6kik54q6wdhmdjy6jp91rfl2i")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (arguments
+     (list
+      #:texlive-latex-base #f
+      #:create-formats #~(list "luahbtex")))
+    (propagated-inputs
+     (list texlive-cm
+           texlive-etex
+           texlive-hyphen-complete
+           texlive-knuth-lib
+           texlive-luatex
+           texlive-plain
+           texlive-tex-ini-files
+           texlive-unicode-data))
+    (home-page "https://ctan.org/pkg/luahbtex")
+    (synopsis "LuaTeX with HarfBuzz library for glyph shaping")
+    (description
+     "LuaHBTeX is a LuaTeX variant that can use the HarfBuzz engine for glyph
+shaping, instead of LuaTeX's built-in shaper.")
+    (license (package-license texlive-luatex))))
+
 ;; TODO: We should be able to build this from the sources on Github with
 ;; texlive-l3build, but I haven't been able to get it to work.
 (define-public texlive-luaotfload