summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2020-06-06 13:08:11 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-06-06 13:08:11 +0200
commit0d582c68eec944c12991a79f288a13c4d753f319 (patch)
tree59551e0886b8226101e5026b09d563692b992a23
parent96f0a465daa0402f87836e13c34980f8fd0d99e4 (diff)
downloadguix-0d582c68eec944c12991a79f288a13c4d753f319.tar.gz
gnu: emacs-clojure-mode: Update to 5.11.0.
* gnu/packages/emacs-xyz.scm (emacs-clojure-mode): Update to 5.11.0.
[native-inputs]: Add emacs-buttercup, remove emacs-ert-runner.  [arguments]:
Update test command.  [description]: Small typographic fixes.
-rw-r--r--gnu/packages/emacs-xyz.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 02a4417417..0d912e7b70 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -6570,7 +6570,7 @@ allowing unprefixed keys to insert their respective characters as expected.")
 (define-public emacs-clojure-mode
   (package
     (name "emacs-clojure-mode")
-    (version "5.6.1")
+    (version "5.11.0")
     (source
      (origin
        (method git-fetch)
@@ -6579,21 +6579,21 @@ allowing unprefixed keys to insert their respective characters as expected.")
              (commit version)))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "1qadymqzs5fn1sb347xzfw8lqq6s85vvkh4kzm35m61g5i2lm86y"))))
+        (base32 "1x1yszp6waa778ki6sw66w1pzcz389wd01gkcldfxxnd7z89ad5d"))))
     (build-system emacs-build-system)
     (native-inputs
-     `(("emacs-dash" ,emacs-dash)
-       ("emacs-s" ,emacs-s)
-       ("ert-runner" ,emacs-ert-runner)))
+     `(("emacs-buttercup" ,emacs-buttercup)
+       ("emacs-dash" ,emacs-dash)
+       ("emacs-s" ,emacs-s)))
     (arguments
      `(#:tests? #t
-       #:test-command '("ert-runner")))
+       #:test-command '("buttercup")))
     (home-page "https://github.com/clojure-emacs/clojure-mode")
     (synopsis "Major mode for Clojure code")
     (description
      "This Emacs package provides font-lock, indentation, navigation and basic
 refactoring for the @uref{http://clojure.org, Clojure programming language}.
-It is recommended to use @code{clojure-mode} with paredit or smartparens.")
+It is recommended to use @code{clojure-mode} with Paredit or Smartparens.")
     (license license:gpl3+)))
 
 (define-public emacs-epl