summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-15 23:19:46 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:11:48 +0200
commit107c61b1d4af65046fb8a3576bb89b82e17c2fbb (patch)
treefd587b4eacbc15120b49a13dbb43642faa07f6d2
parent773bbd5af1fb14d5def6418809f6617bbb60154b (diff)
downloadguix-107c61b1d4af65046fb8a3576bb89b82e17c2fbb.tar.gz
gnu: texlive-fancyhdr: Refresh package definition.
* gnu/packages/tex.scm (texlive-fancyhdr): Remove SIMPLE-TEXLIVE-PACKAGE
call.
-rw-r--r--gnu/packages/tex.scm41
1 files changed, 18 insertions, 23 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index af24823fe8..0e38704799 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6790,29 +6790,24 @@ floats, center, flushleft, and flushright, lists, and pages.")
 (define-deprecated-package texlive-latex-fancybox texlive-fancybox)
 
 (define-public texlive-fancyhdr
-  (let ((template (simple-texlive-package
-                   "texlive-fancyhdr"
-                   (list "doc/latex/fancyhdr/"
-                         "source/latex/fancyhdr/"
-                         "tex/latex/fancyhdr/")
-                   (base32
-                    "15fainwxs22gg4xhwsv1vmjgdhg34dbkir26nnk4pb6jprpwb83f"))))
-    (package
-      (inherit template)
-      (outputs '("out" "doc"))
-      (arguments
-       (substitute-keyword-arguments (package-arguments template)
-         ((#:tex-directory _ '())
-          "latex/fancyhdr")
-         ((#:build-targets _ '())
-          #~(list "fancyhdr.ins"))))
-      (home-page "https://www.ctan.org/pkg/fancyhdr")
-      (synopsis "Extensive control of page headers and footers in LaTeX2e")
-      (description
-       "This package provides extensive facilities, both for constructing
-headers and footers, and for controlling their use (for example, at times when
-LaTeX would automatically change the heading style in use).")
-      (license license:lppl))))
+  (package
+    (name "texlive-fancyhdr")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/fancyhdr/" "source/latex/fancyhdr/"
+                   "tex/latex/fancyhdr/")
+             (base32
+              "15fainwxs22gg4xhwsv1vmjgdhg34dbkir26nnk4pb6jprpwb83f")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/fancyhdr")
+    (synopsis "Extensive control of page headers and footers in LaTeX2e")
+    (description
+     "The package provides extensive facilities, both for constructing headers
+and footers, and for controlling their use (for example, at times when LaTeX
+would automatically change the heading style in use).")
+    (license license:lppl1.3+)))
 
 (define-deprecated-package texlive-latex-fancyhdr texlive-fancyhdr)