summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-17 00:43:22 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:12:21 +0200
commit12dcf8f384f7ca78251cc8714ce734b06548469b (patch)
treee71caf6bcfb992f0b9ca0f726a2152f15d01e323
parentcf5411ecb0bd26f9814a481ffbdf1203d2a597e2 (diff)
downloadguix-12dcf8f384f7ca78251cc8714ce734b06548469b.tar.gz
gnu: texlive-cbfonts: Refresh package definition.
* gnu/packages/tex.scbfonts (texlive-cbfonts): Remove SIMPLE-TEXLIVE-PACKAGE
call.
-rw-r--r--gnu/packages/tex.scm35
1 files changed, 22 insertions, 13 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 57c3e01830..8a454cfa6a 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1119,21 +1119,30 @@ documents.")
 
 (define-public texlive-cbfonts          ;71 MiB of greek fonts
   (package
-    (inherit (simple-texlive-package
-              "texlive-cbfonts"
-              (list "/doc/fonts/cbfonts/"
-                    "/fonts/type1/public/cbfonts/")
-              (base32
-               "01j22cbwq9jkni5vvrpz2mg1799cbx3aq801sni74i8wb1zcf6y1")
-              #:trivial? #t))
+    (name "texlive-cbfonts")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/fonts/cbfonts/"
+                   "fonts/enc/dvips/cbfonts/"
+                   "fonts/map/dvips/cbfonts/"
+                   "fonts/source/public/cbfonts/"
+                   "fonts/tfm/public/cbfonts/"
+                   "fonts/type1/public/cbfonts/")
+             (base32
+              "0l0dpgvngah227snzk6j5hf3kxs5cz5jvlpkv8pbapw6jx084np6")))
+    (outputs '("out" "doc"))
+    ;; FIXME: Font metrics cannot be generated due to "bad pos" errors.
+    (build-system texlive-build-system)
     (propagated-inputs (list texlive-cbfonts-fd))
-    (home-page "https://www.ctan.org/pkg/cbgreek-complete")
+    (home-page "https://ctan.org/pkg/cbgreek-complete")
     (synopsis "Complete set of Greek fonts")
-    (description "This bundle presents the whole of Beccari's original Greek
-font set, which use the @i{Lispiakos} font shape derived from the shape of the
-fonts used in printers' shops in Lispia.  The fonts are available both as
-Metafont source and in Adobe Type 1 format, and at the same wide set of design
-sizes as are such font sets as the EC fonts.")
+    (description
+     "This bundle presents the whole of Beccari's original Greek font set,
+which use the @i{Lispiakos} font shape derived from the shape of the fonts
+used in printers' shops in Lispia.  The fonts are available both as Metafont
+source and in Adobe Type 1 format, and at the same wide set of design sizes as
+are such font sets as the EC fonts.")
     (license license:lppl1.3c+)))
 
 (define-public texlive-cbfonts-fd