summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-02-03 19:29:35 +0100
committerMarius Bakke <marius@gnu.org>2022-02-03 23:39:47 +0100
commit16701a3c1dfefabe12770b064be293425964117f (patch)
tree45a969da9de4c283fd6d1b259dcd8434128f91db
parent3f0d01b2df782cbe875bf591242a331117604f1b (diff)
downloadguix-16701a3c1dfefabe12770b064be293425964117f.tar.gz
gnu: b4: Fix build failure.
* gnu/packages/version-control.scm (b4)[arguments]: Delete sanity-check phase.
-rw-r--r--gnu/packages/version-control.scm12
1 files changed, 10 insertions, 2 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index e0bac5399a..c29de9cf2a 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -15,7 +15,7 @@
 ;;; Copyright © 2017 Vasile Dumitrascu <va511e@yahoo.com>
 ;;; Copyright © 2017 Clément Lassieur <clement@lassieur.org>
 ;;; Copyright © 2017, 2020 EuAndreh <eu@euandre.org>
-;;; Copyright © 2017, 2018, 2020 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2017, 2018, 2020, 2022 Marius Bakke <marius@gnu.org>
 ;;; Copyright © 2017 Stefan Reichör <stefan@xsteve.at>
 ;;; Copyright © 2017, 2020 Oleg Pykhalov <go.wigust@gmail.com>
 ;;; Copyright © 2018 Sou Bunnbu <iyzsong@member.fsf.org>
@@ -63,6 +63,7 @@
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix utils)
   #:use-module (guix packages)
+  #:use-module (guix gexp)
   #:use-module (guix download)
   #:use-module (guix git-download)
   #:use-module (guix hg-download)
@@ -2572,7 +2573,14 @@ based on a manifest file published by servers.")
              (("~=") ">="))
            #t))))
     (build-system python-build-system)
-    (arguments '(#:tests? #f))          ; No tests.
+    (arguments
+     (list #:tests? #f                  ;no tests
+           #:phases
+           #~(modify-phases %standard-phases
+               ;; XXX: dnspython attempts to read /etc/resolv.conf when loading
+               ;; resolver.py, which breaks the sanity check in dependent
+               ;; packages.  This should rather be fixed in dnspython.
+               (delete 'sanity-check))))
     (inputs
      (list python-dkimpy python-dnspython python-requests))
     (home-page "https://git.kernel.org/pub/scm/utils/b4/b4.git")