summary refs log tree commit diff
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2017-07-12 19:55:56 +0530
committerArun Isaac <arunisaac@systemreboot.net>2017-07-14 15:39:29 +0530
commit28a96f2aa1feb62ca8943f2b6e4cecb35021763f (patch)
treea82663002d835f1558835fc07eb3eca2e1599bcd
parentcca9c756613201baec6655b4d7376727179e9951 (diff)
downloadguix-28a96f2aa1feb62ca8943f2b6e4cecb35021763f.tar.gz
gnu: wayland: Add workaround for graphviz 2.40.1.
* gnu/packages/freedesktop.scm (wayland)[arguments]: Add fix-graphviz phase.
-rw-r--r--gnu/packages/freedesktop.scm12
1 files changed, 11 insertions, 1 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index a9a7e08da1..d0d7604b1e 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -367,7 +367,17 @@ Python.")
                (base32
                 "0lgywr1m0d79vr4s8aimj8a307nss29hhy68gjpqj7m667055c39"))))
     (build-system gnu-build-system)
-    (arguments `(#:parallel-tests? #f))
+    (arguments
+     `(#:parallel-tests? #f
+       #:phases
+       (modify-phases %standard-phases
+         ;; Remove record shapes to workaround graphviz 2.40.1 problems
+         ;; http://www.graphviz.org/content/i-havent-been-able-render-these-files-graphviz-226
+         ;; This will likely be fixed upstream in the next release
+         (add-before 'build 'fix-graphviz
+           (lambda _
+             (substitute* "doc/doxygen/dot/x-architecture.gv"
+               (("Mrecord") "none")))))))
     (native-inputs
      `(("doxygen" ,doxygen)
        ("graphviz" ,graphviz)