summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-10-21 12:33:01 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-10-21 23:06:45 +0200
commit2ba2d62c69409255e0c00c480c424c668cba845f (patch)
treefa39fb5e5ed046383a2a74cbe34b15b9b9c15c79
parent1d18ee6dfd99d9945a0e8eae7557250a1bdc6306 (diff)
downloadguix-2ba2d62c69409255e0c00c480c424c668cba845f.tar.gz
gnu: python2-bx-python: Update to 0.8.2.
* gnu/packages/bioinformatics.scm (python2-bx-python): Update to 0.8.2.
[source]: Remove obsolete snippet.
[inputs]: Move python2-numpy from here...
[propagated-inputs]: ...to here; add python2-six.
[native-inputs]: Add python2-lzo and python2-cython.
[home-page]: Update to new home at Github.
-rw-r--r--gnu/packages/bioinformatics.scm24
1 files changed, 10 insertions, 14 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 593b5b6202..dee8a975b9 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -1477,31 +1477,27 @@ well as many of the command line options.")
 (define-public python2-bx-python
   (package
     (name "python2-bx-python")
-    (version "0.7.3")
+    (version "0.8.2")
     (source (origin
               (method url-fetch)
               (uri (pypi-uri "bx-python" version))
               (sha256
                (base32
-                "15z2w3bvnc0n4qmb9bd6d8ylc2h2nj883x2w9iixf4x3vki9b22i"))
-              (modules '((guix build utils)))
-              (snippet
-               '(begin
-                  (substitute* "setup.py"
-                    ;; remove dependency on outdated "distribute" module
-                    (("^from distribute_setup import use_setuptools") "")
-                    (("^use_setuptools\\(\\)") ""))
-                  #t))))
+                "11kksg2rbzihpmcid823xvg42xi88m7sz58rzk29abybkxy0rszs"))))
     (build-system python-build-system)
     (arguments
      `(#:tests? #f ;tests fail because test data are not included
        #:python ,python-2))
-    (inputs
+    (propagated-inputs
      `(("python-numpy" ,python2-numpy)
-       ("zlib" ,zlib)))
+       ("python-six" ,python2-six)))
+    (inputs
+     `(("zlib" ,zlib)))
     (native-inputs
-     `(("python-nose" ,python2-nose)))
-    (home-page "http://bitbucket.org/james_taylor/bx-python/")
+     `(("python-lzo" ,python2-lzo)
+       ("python-nose" ,python2-nose)
+       ("python-cython" ,python2-cython)))
+    (home-page "https://github.com/bxlab/bx-python")
     (synopsis "Tools for manipulating biological data")
     (description
      "bx-python provides tools for manipulating biological data, particularly