summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-20 10:55:24 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-20 11:17:34 +0200
commit3342f91035e1a5f49a8f54970b8c1e7822359f75 (patch)
treeb155c22930792f22caa5fd63eb09371890903b05
parent3f6c9b70d5a03745e27cb123bbe6ac896a6ba74a (diff)
downloadguix-3342f91035e1a5f49a8f54970b8c1e7822359f75.tar.gz
gnu: Add texlive-localloc.
* gnu/packages/tex.scm (texlive-localloc): New variable.
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index be0bc10c60..6f88c45b3f 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3049,6 +3049,27 @@ to make the text fit the box.  Note that letterspacing is not ordinarily
 considered acceptable in modern typesetting of English.")
     (license license:knuth)))
 
+(define-public texlive-localloc
+  (package
+    (name "texlive-localloc")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/generic/localloc/"
+                   "source/generic/localloc/"
+                   "tex/generic/localloc/")
+             (base32
+              "0vcfdxh800ksr4wrrvykdm27qvlhqkylbik4j93pr59g13h9g90f")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/localloc")
+    (synopsis "Macros for localizing TeX register allocations")
+    (description
+     "This package approaches the problem of the shortage of registers, by
+providing a mechanism for local allocation.  The package works with Plain TeX
+and LaTeX.")
+    (license license:knuth)))
+
 (define-public texlive-tex
   (package
     (name "texlive-tex")