summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-16 17:30:44 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:12:08 +0200
commit4d76be518813bd1ec27d7e29df57ec51497ce6e2 (patch)
tree1312199466a35b8bba59fb1d446dcfd9d8571437
parentb1554676a0af15b4eca217a4f7e5fbba47691cf5 (diff)
downloadguix-4d76be518813bd1ec27d7e29df57ec51497ce6e2.tar.gz
gnu: texlive-calrsfs: Refresh package definition.
* gnu/packages/tex.scm (texlive-calrsfs): Remove SIMPLE-TEXLIVE-PACKAGE
call.
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 12 insertions, 8 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 5a63a77925..bc3b1cab4b 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6061,15 +6061,19 @@ including files to the root of the tree).  The package supersedes FiNK.")
 
 (define-public texlive-calrsfs
   (package
-    (inherit
-     (simple-texlive-package
-      "texlive-calrsfs"
-      (list "doc/latex/calrsfs/" "tex/latex/calrsfs/")
-      (base32 "0aqa0k0zzzicx5nynd29i9pdb7a4j6fvf1xwrbm4qg64pl55i6xa")
-      #:trivial? #t))
-    (home-page "https://ctan.org/macros/latex/contrib/calrsfs")
+    (name "texlive-calrsfs")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/calrsfs/" "tex/latex/calrsfs/")
+             (base32
+              "0aqa0k0zzzicx5nynd29i9pdb7a4j6fvf1xwrbm4qg64pl55i6xa")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/calrsfs")
     (synopsis "Copperplate calligraphic letters in LaTeX")
-    (description "This package provides a math interface to the Rsfs fonts.")
+    (description "This package provides a maths interface to the @code{rsfs}
+fonts.")
     (license license:public-domain)))
 
 (define-public texlive-capt-of