summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-14 11:36:20 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:11:00 +0200
commit50e49cf9b4507a4b2532f47050de3b24bcbad86b (patch)
treee3c82346d011e60c8384c390f864ef2710b81d71
parent58d6740f0c5829409d751f4adac5177e11892649 (diff)
downloadguix-50e49cf9b4507a4b2532f47050de3b24bcbad86b.tar.gz
gnu: texlive-latex-needspace -> texlive-needspace.
* gnu/packages/tex.scm (texlive-needspace): New variable.
(texlive-latex-needspace): Deprecate variable.
* gnu/packages/maths.scm (hypre)[native-inputs]:
* gnu/packages/sphinx.scm (python-sphinx)[propagated-inputs]: Use new name.
-rw-r--r--gnu/packages/maths.scm2
-rw-r--r--gnu/packages/sphinx.scm2
-rw-r--r--gnu/packages/tex.scm35
3 files changed, 20 insertions, 19 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index a6a015eca0..dc1d62e4ad 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -5803,7 +5803,7 @@ set.")
                                      texlive-listofitems
                                      texlive-multirow
                                      texlive-natbib
-                                     texlive-latex-needspace
+                                     texlive-needspace
                                      texlive-newunicodechar
                                      texlive-parskip
                                      texlive-sectsty
diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index 4c6d7263dd..b2ad5d99e8 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -122,7 +122,7 @@
            texlive-kvoptions
            texlive-latex-base           ;alltt, atbegshi, makeidx, textcomp
            texlive-ltxcmds
-           texlive-latex-needspace
+           texlive-needspace
            texlive-oberdiek             ;hypcap
            texlive-parskip
            texlive-preview
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index d807e97d9d..c074811fd7 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -9240,31 +9240,32 @@ and after the formatted number.")
 
 (define-deprecated-package texlive-latex-numprint texlive-numprint)
 
-(define-public texlive-latex-needspace
+(define-public texlive-needspace
   (package
-    (name "texlive-latex-needspace")
+    (name "texlive-needspace")
     (version (number->string %texlive-revision))
-    (source (origin
-              (method svn-fetch)
-              (uri (texlive-ref "latex" "needspace"))
-              (file-name (string-append name "-" version "-checkout"))
-              (sha256
-               (base32
-                "0kw80f5jh4gdpa2ka815abza3gr5z8b929w0745vrlc59pl0017y"))))
+    (source (texlive-origin name version
+                            (list "doc/latex/needspace/"
+                                  "source/latex/needspace/"
+                                  "tex/latex/needspace/")
+                            (base32
+                             "12hbvv1w6b1k29qjvp72bkpnzsxpvrimzshllwinrxh9rx1mn550")))
+    (outputs '("out" "doc"))
     (build-system texlive-build-system)
     (arguments
-     '(#:tex-directory "latex/needspace"
-       #:tex-format "latex"))
-    (inputs
+     (list #:tex-format "latex"))
+    (native-inputs
      (list texlive-filecontents))
-    (home-page "https://www.ctan.org/pkg/needspace")
+    (home-page "https://ctan.org/pkg/needspace")
     (synopsis "Insert pagebreak if not enough space")
     (description
-     "Provides commands to disable pagebreaking within a given vertical
-space.  If there is not enough space between the command and the bottom of the
-page, a new page will be started.")
+     "This package provides commands to disable pagebreaking within a given
+vertical space.  If there is not enough space between the command and the
+bottom of the page, a new page will be started.")
     (license license:lppl)))
 
+(define-deprecated-package texlive-latex-needspace texlive-needspace)
+
 (define-public texlive-latex-changepage
   (package
     (name "texlive-latex-changepage")
@@ -12271,7 +12272,7 @@ Polish of standard ``LaTeX names''.")
        "tex/latex/mdframed/")
       (base32 "1i5rm946wg43rjckxlfhx79zfx5cgd3bxk71206hd1dqkrgpdpa8")
       #:trivial? #t))
-    (propagated-inputs (list texlive-latex-needspace
+    (propagated-inputs (list texlive-needspace
                              texlive-zref))
     (home-page "https://ctan.org/pkg/mdframed")
     (synopsis "Framed environments that can split at page boundaries")