summary refs log tree commit diff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2019-01-28 14:53:58 +0000
committerChristopher Baines <mail@cbaines.net>2019-02-14 21:37:59 +0000
commit566f71f8b82d132e32acafd2b73a14a6680cac5c (patch)
treee89c812970e4a0146a9320bb5858f893c5159fab
parentb8aecc31b4f3cdad7a3d5b44af3e541ad1ad9d03 (diff)
downloadguix-566f71f8b82d132e32acafd2b73a14a6680cac5c.tar.gz
gnu: Add ruby-bump.
Required for ruby-parallel.

* gnu/packages/ruby.scm (ruby-bump): New variable.
-rw-r--r--gnu/packages/ruby.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index df0969eb2d..854b5c2cdc 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -584,6 +584,28 @@ supported: XML Markup and XML Events.")
     (home-page "https://github.com/jimweirich/builder")
     (license license:expat)))
 
+(define-public ruby-bump
+  (package
+    (name "ruby-bump")
+    (version "0.7.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (rubygems-uri "bump" version))
+       (sha256
+        (base32
+         "1xinbr9rzh6cj75x24niwgqcnbhdxc68a8bc41lk8xv6fd906fym"))))
+    (build-system ruby-build-system)
+    (arguments
+     '(;; No included tests
+       #:tests? #f))
+    (synopsis "Tool for working with Rubygems")
+    (description
+     "Bump provides commands to manage Rubygem versioning, updating to the
+next patch version for example.")
+    (home-page "https://github.com/gregorym/bump")
+    (license license:expat)))
+
 (define-public ruby-rjb
   (package
     (name "ruby-rjb")