summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-10-05 16:29:51 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-10-05 21:36:38 +0200
commit57c0804dcb17989bf587119b66c5cb70ba03e485 (patch)
tree0fab3e958adf3c09dc8c2f41970054ea55731e5a
parentd84420d4949e3e50531de3802dcdcd36a834481e (diff)
downloadguix-57c0804dcb17989bf587119b66c5cb70ba03e485.tar.gz
gnu: libzen: Update to 0.4.39.
* gnu/packages/cpp.scm (libzen): Update to 0.4.39.
[arguments]: Don't explicitly return #t from phases.
-rw-r--r--gnu/packages/cpp.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 4af71ba93a..26b4758728 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -144,7 +144,7 @@ use by the C++ Core Guidelines maintained by the Standard C++ Foundation.")
 (define-public libzen
   (package
     (name "libzen")
-    (version "0.4.38")
+    (version "0.4.39")
     (source (origin
               (method url-fetch)
               ;; Warning: This source has proved unreliable 1 time at least.
@@ -155,7 +155,7 @@ use by the C++ Core Guidelines maintained by the Standard C++ Foundation.")
                                   "libzen_" version ".tar.bz2"))
               (sha256
                (base32
-                "1nkygc17sndznpcf71fdrhwpm8z9a3hc9csqlafwswh49axhfkjr"))))
+                "1rwaxmid9iv65n0y6xlcyxxydsvihjni9ldxpg6pbqz43amp49xx"))))
     (native-inputs
      `(("autoconf" ,autoconf)
        ("automake" ,automake)
@@ -167,8 +167,7 @@ use by the C++ Core Guidelines maintained by the Standard C++ Foundation.")
        (modify-phases %standard-phases
          (add-after 'unpack 'pre-configure
            (lambda _
-             (chdir "Project/GNU/Library")
-             #t)))))
+             (chdir "Project/GNU/Library"))))))
     (home-page "https://github.com/MediaArea/ZenLib")
     (synopsis "C++ utility library")
     (description "ZenLib is a C++ utility library.  It includes classes for handling