summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-15 22:02:35 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:11:40 +0200
commit606a75bde562263137040bdbaac26b4eb91f571f (patch)
treed372c123f5ad3fc61883f43198b1951d70d9f510
parent238b1c4db6b96a33a1d7ecc980f1b8a3108d37b1 (diff)
downloadguix-606a75bde562263137040bdbaac26b4eb91f571f.tar.gz
gnu: texlive-titlesec: Refresh package definition.
* gnu/packages/tex.scm (texlive-titlesec): Remove SIMPLE-TEXLIVE-PACKAGE
call.
-rw-r--r--gnu/packages/tex.scm19
1 files changed, 11 insertions, 8 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index fe2775e8b2..1e38bb074c 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -8340,13 +8340,16 @@ LGR.  The package doesn't (currently) support mathematics.")
 
 (define-public texlive-titlesec
   (package
-    (inherit
-     (simple-texlive-package
-      "texlive-titlesec"
-      (list "doc/latex/titlesec/" "tex/latex/titlesec/")
-      (base32 "01nwh4p15xblc3kgivjliihy9kr8yr2cqsf9wn2iwqv1njx0i2zw")
-      #:trivial? #t))
-    (home-page "https://ctan.org/macros/latex/contrib/titlesec")
+    (name "texlive-titlesec")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/titlesec/" "tex/latex/titlesec/")
+             (base32
+              "01nwh4p15xblc3kgivjliihy9kr8yr2cqsf9wn2iwqv1njx0i2zw")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/titlesec")
     (synopsis "Select alternative section titles")
     (description
      "This package provides an interface to sectioning commands for selection
@@ -8354,7 +8357,7 @@ from various title styles, e.g. for marginal titles and to change the font of
 all headings with a single command, also providing simple one-step page
 styles.  It also includes a package to change the page styles when there are
 floats in a page.  You may assign headers/footers to individual floats, too.")
-    (license license:lppl)))
+    (license license:expat)))
 
 (define-deprecated-package texlive-latex-titlesec texlive-titlesec)