summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2023-07-16 02:00:01 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2023-07-16 02:00:38 +0200
commit6168ad89f2ccd3872414e8adfe5efcaf350726ca (patch)
tree1d6aec1e8b07a9764f0c364f971f1d12a2f59b4f
parenta9e788c008b1661bc31f6fa17b35048861cfc9f7 (diff)
downloadguix-6168ad89f2ccd3872414e8adfe5efcaf350726ca.tar.gz
gnu: adanaxisgpl: Install the .mush files (again).
This out of an abundance of caution more than anything.

* gnu/packages/games.scm (adanaxisgpl)[arguments]: Add an 'install-data phase.
[native-inputs]: Use a later commit for adanaxis-data.
-rw-r--r--gnu/packages/games.scm18
1 files changed, 15 insertions, 3 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index be8f16af15..ec084553da 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -354,16 +354,28 @@ the style of similar games for the Commodore+4.")
            (replace 'bootstrap
              (lambda _
                (invoke "perl" "autogen.pl" "adanaxis"
-                       "--type=gpl" "--dist=debian"))))))
+                       "--type=gpl" "--dist=debian")))
+           (add-after 'install 'install-data
+             ;; XXX This was copied from the original (pre-Git) adanaxisgpl
+             ;; package.  While the game appears to play fine without it,
+             ;; I cannot prove that it's not missing *something*, so keep it.
+             (lambda* (#:key inputs outputs #:allow-other-keys)
+               (let ((share (string-append (assoc-ref outputs "out")
+                                           "/share/" ,name "-" ,version)))
+                 (copy-recursively (search-input-directory inputs "mush")
+                                   (string-append share "/mush"))))))))
       (native-inputs
        (list (origin
                (method git-fetch)
                (uri (git-reference
                      (url "https://github.com/mushware/adanaxis-data")
-                     (commit commit)))
+                     ;; XXX There is a tag matching COMMIT, but it does not
+                     ;; contain the .mush files installed by 'install-data.
+                     ;; Use this later commit as long as we install them.
+                     (commit "6a5b5ad8ee82c10e67bc4c12b16404944fd5754d")))
                (file-name (git-file-name "adanaxis-data" version))
                (sha256
-                (base32 "1xkn0ap5kfqd306ac072406ajihwwllaczc2v2hxiadlxd191dgx")))
+                (base32 "15am9ziq1i53sz0r7sjh2z329b52fkzj6fz7ms1nqqzdfmp11r3d")))
              (origin
                (method git-fetch)
                (uri (git-reference