summary refs log tree commit diff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2015-09-01 17:33:52 -0400
committerAlex Kost <alezost@gmail.com>2015-09-02 21:55:31 +0300
commit641c9871a5b903ea4cf3fbfa127a5bf2c8372542 (patch)
treeb59d312cbf71c19ba2468ce50cfbc5cecf0b9324
parent89b2e0b0b846d985d76553a3759a0bd7f77a583f (diff)
downloadguix-641c9871a5b903ea4cf3fbfa127a5bf2c8372542.tar.gz
gnu: Add python-msgpack.
* gnu/packages/python.scm (python-msgpack, python2-msgpack): New variables.

Signed-off-by: Alex Kost <alezost@gmail.com>
-rw-r--r--gnu/packages/python.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 68bcbf5c34..313c6251c6 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -4713,3 +4713,28 @@ should be stored on various operating systems.")
 
 (define-public python2-llfuse
   (package-with-python2 python-llfuse))
+
+(define-public python-msgpack
+  (package
+    (name "python-msgpack")
+    (version "0.4.6")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "https://pypi.python.org/packages/source/m/"
+                    "msgpack-python/msgpack-python-" version ".tar.gz"))
+              (sha256
+               (base32
+                "1527c76b6fn4zzkgfq5xvhh7x9a9686g7fjiz717rw5vklf5ik5z"))))
+    (build-system python-build-system)
+    (native-inputs
+     `(("python-setuptools" ,python-setuptools)))
+    (synopsis "MessagePack (de)serializer")
+    (description "MessagePack is a fast, compact binary serialization format,
+suitable for similar data to JSON.  This package provides CPython bindings for
+reading and writing MessagePack data.")
+    (home-page "https://pypi.python.org/pypi/msgpack-python/")
+    (license asl2.0)))
+
+(define-public python2-msgpack
+  (package-with-python2 python-msgpack))