summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-04-14 13:31:33 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-04-14 13:31:33 +0200
commit67941709e21c7f14bec0924aa6a893840c70ec68 (patch)
treef51964d7710e7f9d3cd5add303c15140da34928d
parentcab66570947a8d6fc1acd380151e91a65cf4a6bb (diff)
downloadguix-67941709e21c7f14bec0924aa6a893840c70ec68.tar.gz
gnu: r-aneufinder: Move to packages section.
* gnu/packages/bioconductor.scm (r-aneufinder): Move this definition out of
the section for Bioconductor experiments packages.
-rw-r--r--gnu/packages/bioconductor.scm84
1 files changed, 42 insertions, 42 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index e6f462b697..5a20fbbc64 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -1173,48 +1173,6 @@ ranking by fold-change and visualization.")
    (description "This package contains data used by @code{AneuFinder}.")
    (license license:artistic2.0)))
 
-(define-public r-aneufinder
-  (package
-    (name "r-aneufinder")
-    (version "1.22.0")
-    (source (origin
-              (method url-fetch)
-              (uri (bioconductor-uri "AneuFinder" version))
-              (sha256
-               (base32
-                "0xn8952fkchhx7m8dam6gjy86j551xp1cs67510s1qrmfgzpkjp0"))))
-    (build-system r-build-system)
-    (native-inputs
-     (list r-knitr))
-    (propagated-inputs
-     (list r-genomicranges
-           r-aneufinderdata
-           r-ecp
-           r-foreach
-           r-doparallel
-           r-biocgenerics
-           r-s4vectors
-           r-genomeinfodb
-           r-iranges
-           r-rsamtools
-           r-bamsignals
-           r-dnacopy
-           r-biostrings
-           r-genomicalignments
-           r-ggplot2
-           r-reshape2
-           r-ggdendro
-           r-ggrepel
-           r-reordercluster
-           r-mclust
-           r-cowplot))
-    (home-page "https://bioconductor.org/packages/AneuFinder/")
-    (synopsis "Copy number variation analysis in single-cell-sequencing data")
-    (description "This package implements functions for copy number variant
-calling, plotting, export and analysis from whole-genome single cell
-sequencing data.")
-    (license license:artistic2.0)))
-
 (define-public r-arrmdata
   (package
     (name "r-arrmdata")
@@ -1587,6 +1545,48 @@ TCGAbiolinksGUI package.")
 
 ;;; Packages
 
+(define-public r-aneufinder
+  (package
+    (name "r-aneufinder")
+    (version "1.22.0")
+    (source (origin
+              (method url-fetch)
+              (uri (bioconductor-uri "AneuFinder" version))
+              (sha256
+               (base32
+                "0xn8952fkchhx7m8dam6gjy86j551xp1cs67510s1qrmfgzpkjp0"))))
+    (build-system r-build-system)
+    (native-inputs
+     (list r-knitr))
+    (propagated-inputs
+     (list r-genomicranges
+           r-aneufinderdata
+           r-ecp
+           r-foreach
+           r-doparallel
+           r-biocgenerics
+           r-s4vectors
+           r-genomeinfodb
+           r-iranges
+           r-rsamtools
+           r-bamsignals
+           r-dnacopy
+           r-biostrings
+           r-genomicalignments
+           r-ggplot2
+           r-reshape2
+           r-ggdendro
+           r-ggrepel
+           r-reordercluster
+           r-mclust
+           r-cowplot))
+    (home-page "https://bioconductor.org/packages/AneuFinder/")
+    (synopsis "Copy number variation analysis in single-cell-sequencing data")
+    (description "This package implements functions for copy number variant
+calling, plotting, export and analysis from whole-genome single cell
+sequencing data.")
+    (license license:artistic2.0)))
+
 (define-public r-biocversion
   (package
     (name "r-biocversion")