summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-07-20 17:43:15 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-07-21 13:19:33 +0300
commit696b22141cb53b9797c80f49079c0a0fcd60ba64 (patch)
treefc715570c837532da5fd03470b0c62f46a32bccc
parent0867cdc5148ed9c066f73d4213ad342bd332c070 (diff)
downloadguix-696b22141cb53b9797c80f49079c0a0fcd60ba64.tar.gz
gnu: parted: Skip tests when cross-compiling.
* gnu/packages/disk.scm (parted)[arguments]: Adjust #:tests? to skip
tests when cross-compiling.
-rw-r--r--gnu/packages/disk.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/disk.scm b/gnu/packages/disk.scm
index 35ffcf173e..21e8775e83 100644
--- a/gnu/packages/disk.scm
+++ b/gnu/packages/disk.scm
@@ -3,7 +3,7 @@
 ;;; Copyright © 2015 Mathieu Lirzin <mthl@gnu.org>
 ;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
 ;;; Copyright © 2016, 2018–2022 Tobias Geerinckx-Rice <me@tobias.gr>
-;;; Copyright © 2016, 2019, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2019-2021, 2023 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2016, 2023 Janneke Nieuwenhuizen <janneke@gnu.org>
 ;;; Copyright © 2016 Roel Janssen <roel@gnu.org>
 ;;; Copyright © 2016, 2017 Marius Bakke <mbakke@fastmail.com>
@@ -259,7 +259,8 @@ tmpfs/ramfs filesystems.")
       #:configure-flags (if (target-hurd?)
                             #~'("--disable-device-mapper")
                             #~'())
-      #:tests? (not (target-hurd?))
+      #:tests? (not (or (target-hurd?)
+                        (%current-target-system)))
       #:phases
       #~(modify-phases %standard-phases
           (add-after 'unpack 'fix-locales-and-python