summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-07-20 17:46:27 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-07-21 13:19:33 +0300
commit6bda806416b8e6032ef1047c5feed776b6cc0493 (patch)
treed188ee82d85a533298ec1cf8b683ad52d51159a8
parentc11afc46777bfdf3dc222062cfe3518c0d8a657a (diff)
downloadguix-6bda806416b8e6032ef1047c5feed776b6cc0493.tar.gz
gnu: swig: Skip tests when cross-compiling.
* gnu/packages/swig.scm (swig)[arguments]: Adjust #:tests? to skip tests
when cross-compiling.
-rw-r--r--gnu/packages/swig.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/swig.scm b/gnu/packages/swig.scm
index 42996fa812..3f38cd9f9f 100644
--- a/gnu/packages/swig.scm
+++ b/gnu/packages/swig.scm
@@ -2,7 +2,7 @@
 ;;; Copyright © 2013, 2015, 2016 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
 ;;; Copyright © 2018, 2021 Marius Bakke <marius@gnu.org>
-;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2019, 2023 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2020 Arun Isaac <arunisaac@systemreboot.net>
 ;;; Copyright © 2023 Janneke Nieuwenhuizen <janneke@gnu.org>
 ;;;
@@ -56,7 +56,8 @@
                          perl))
                      ;;("python" ,python-wrapper)
     (inputs (list pcre))
-    (arguments (list #:tests? (not (target-hurd?))))
+    (arguments (list #:tests? (not (or (target-hurd?)
+                                       (%current-target-system)))))
     (home-page "https://swig.org/")
     (synopsis
      "Interface compiler that connects C/C++ code to higher-level languages")