summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-20 11:01:21 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-20 11:17:40 +0200
commit7151746bb58ab42d7b55f36bfa7611f1ad703197 (patch)
treeacde0a56dd89f9c3ba6c13d218d0eef438077e35
parent0b7ba05ac7302730fcc952ce1aeb1eddf0ccbf03 (diff)
downloadguix-7151746bb58ab42d7b55f36bfa7611f1ad703197.tar.gz
gnu: Add texlive-plnfss.
* gnu/packages/tex.scm (texlive-plnfss): New variable.
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 3066a7d1f9..ba05d076ff 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3437,6 +3437,29 @@ documents.  The paragraphs generated contain many f-groups (@samp{ff},
 use.")
     (license license:lppl)))
 
+(define-public texlive-plnfss
+  (package
+    (name "texlive-plnfss")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/plain/plnfss/" "tex/plain/plnfss/")
+             (base32
+              "1cgnp8y9m0ziq1pfvjx83vi0r0k5xpckk0kiijy0g80wd3s4zbsd")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/plnfss")
+    (synopsis "Font selection for Plain TeX")
+    (description
+     "Plnfss is a set of macros to provide easy font access (somewhat similar
+to NFSS but with some limitations) with Plain TeX.  Plnfss can automatically
+make use of PSNFSS @code{fd} files, i.e., when an Adobe Type 1 is used the
+relevant @code{fd} file will be loaded automatically.  For @code{cmr}-like
+fonts (@code{ec}, @code{vnr}, @code{csr} or @code{plr} fonts), a special
+format called @code{pfd} (plain @code{fd}) is required and must be loaded
+manually.")
+    (license license:lppl)))
+
 (define-public texlive-tex
   (package
     (name "texlive-tex")