summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-16 17:22:27 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:18:45 +0200
commit71a4228b9c29cabd8bf93468ea1fb1adb0401337 (patch)
treea32d21e09aa807fa37f548beca247e94a87b0d7d
parentdb4c351f1c7d229360965045201079c58991ea9b (diff)
downloadguix-71a4228b9c29cabd8bf93468ea1fb1adb0401337.tar.gz
gnu: Add texlive-spix.
* gnu/packages/tex.scm (texlive-spix): New variable.
-rw-r--r--gnu/packages/tex.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index a92f940d2b..d40e0ed144 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3272,6 +3272,32 @@ SeeTeX project.
 @end itemize")
     (license license:expat)))
 
+(define-public texlive-spix
+  (package
+    (name "texlive-spix")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/man/man1/spix.1"
+                   "doc/man/man1/spix.man1.pdf"
+                   "doc/support/spix/" "scripts/spix/")
+             (base32
+              "0k1vkkrn14svqarbqpfccw3qqiz1slngngrwgs4fj5y0ilrym0bf")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (arguments (list #:link-scripts #~(list "spix.py")))
+    (inputs (list python))
+    (home-page "https://ctan.org/pkg/spix")
+    (synopsis "Yet another TeX compilation tool")
+    (description
+     "SpiX offers a way to store information about the compilation process for
+a TeX file inside the TeX file itself.  Just write the commands as comments in
+the TeX files, and SpiX will extract and run those commands.  Everything is
+stored in the TeX file (so that you are not missing some piece of information
+that is located somewhere else), in a human-readable format (no need to know
+SpiX to understand it).")
+    (license license:gpl3+)))
+
 (define-public texlive-tex-ini-files
   (package
     (name "texlive-tex-ini-files")