summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-03-14 01:24:41 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-03-14 12:02:53 +0100
commit75ca2cdaff06b125b39a4f71499efcb73aa94b6c (patch)
tree73d4efc289138586f41bac8ee312f6629fb2cf40
parentef4c5a413e099e58ccfddff1586d941b7c3ab2df (diff)
downloadguix-75ca2cdaff06b125b39a4f71499efcb73aa94b6c.tar.gz
gnu: innoextract: Fix build failure with recent Boost and CMake.
* gnu/packages/compression.scm (innoextract)[arguments]: Add #:configure-flags
to prevent usage of Boost's CMake scripts.  While at it, remove the obsolete
 #:phases.
-rw-r--r--gnu/packages/compression.scm12
1 files changed, 1 insertions, 11 deletions
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index c3b5632cba..0dec28940b 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -1781,17 +1781,7 @@ single-member files which can't be decompressed in parallel.")
    (build-system cmake-build-system)
    (arguments
     `(#:tests? #f
-      #:phases (modify-phases %standard-phases
-                 (add-before 'configure 'glibc-is-already-a-system-library
-                   (lambda _
-                     ;; Prevent the build system from passing the glibc
-                     ;; header files to GCC as "system headers", because
-                     ;; it conflicts with the system headers already known
-                     ;; to GCC, causing #include_next failures.
-                     (substitute* "CMakeLists.txt"
-                       (("include_directories\\(SYSTEM \\$\\{iconv")
-                        "include_directories(${iconv"))
-                     #t)))))
+      #:configure-flags '("-DBoost_NO_BOOST_CMAKE=ON")))
    (inputs `(("boost" ,boost)
              ("libiconv" ,libiconv)
              ("xz" ,xz)))