summary refs log tree commit diff
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2022-01-04 23:47:54 +0100
committerEfraim Flashner <efraim@flashner.co.il>2022-01-10 15:15:37 +0200
commit782eaa180e4815c560ffc622b02f82cc0d7079b1 (patch)
treea53f02577db8a8b489daf85b6e5360c20ac33207
parent5d697044a84b03e83ea4716022453cf0d26f6b4a (diff)
downloadguix-782eaa180e4815c560ffc622b02f82cc0d7079b1.tar.gz
gnu: Add julia-intervaltrees.
* gnu/packages/julia-xyz.scm (julia-intervaltrees): New variable.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/julia-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 27daf975f1..5185832765 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -2807,6 +2807,31 @@ encourage type-piracy for the reason that only one interval package can
 unambiguously define the @code{..} and @code{±} operators.")
     (license license:expat)))
 
+(define-public julia-intervaltrees
+  ;; Last upstream release on May 2020 and this last release does not contain
+  ;; the file Project.toml.
+  (let ((commit "e37edab61568d08141a3e9c25ec55caac21e5aa5")
+        (revision "1"))
+    (package
+      (name "julia-intervaltrees")
+      (version (git-version "1.0.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/BioJulia/IntervalTrees.jl")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "01x48a5zrx0833s1kjhf0ml4x9xz8xja4ymran770akmf6968yl9"))))
+      (build-system julia-build-system)
+      (home-page "https://github.com/BioJulia/IntervalTrees.jl")
+      (synopsis "Interval Trees for Julia")
+      (description "This package provides an implementation of an associative
+container mapping @code{(K,V)} pairs via the type @code{IntervalTree{K, V}}.
+The type @code{K} may be any ordered type.")
+      (license license:expat))))
+
 (define-public julia-invertedindices
   (package
     (name "julia-invertedindices")