summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-16 00:18:24 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:11:59 +0200
commit7b46032adf2ea40656643dee75f42eca720d260c (patch)
tree3c3a7714fe72d72cfe5ca328f548783074d930a0
parentdab531f4a0c1e1526900d500a02319cfd9a8dcdd (diff)
downloadguix-7b46032adf2ea40656643dee75f42eca720d260c.tar.gz
gnu: texlive-auxhook: Refresh package definition.
* gnu/packages/tex.scm (texlive-auxhook): Remove SIMPLE-TEXLIVE-PACKAGE
call.
-rw-r--r--gnu/packages/tex.scm35
1 files changed, 16 insertions, 19 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 6327392351..82f9c14423 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3405,26 +3405,23 @@ the @file{.aux} file.")
 (define-deprecated-package texlive-latex-atveryend texlive-atveryend)
 
 (define-public texlive-auxhook
-  (let ((template (simple-texlive-package
-                   "texlive-auxhook"
-                   (list "doc/latex/auxhook/"
-                         "source/latex/auxhook/"
-                         "tex/latex/auxhook/")
-                   (base32
-                    "1qfs7bz8ryp4prr2fw4hwypnfc6yr4rc4wd8qy4rpmab0hab0vdy"))))
-    (package
-      (inherit template)
-      (outputs '("out" "doc"))
-      (arguments
-       (substitute-keyword-arguments (package-arguments template)
-         ((#:build-targets _ '())
-          #~(list "auxhook.dtx"))))
-      (home-page "https://www.ctan.org/pkg/auxhook")
-      (synopsis "Hooks for auxiliary files")
-      (description
-       "This package provides hooks for adding code at the beginning of
+  (package
+    (name "texlive-auxhook")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/auxhook/" "source/latex/auxhook/"
+                   "tex/latex/auxhook/")
+             (base32
+              "1qfs7bz8ryp4prr2fw4hwypnfc6yr4rc4wd8qy4rpmab0hab0vdy")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/auxhook")
+    (synopsis "Hooks for auxiliary files")
+    (description
+     "This package provides hooks for adding code at the beginning of
 @file{.aux} files.")
-      (license license:lppl1.3c+))))
+    (license license:lppl1.3c+)))
 
 (define-deprecated-package texlive-latex-auxhook texlive-auxhook)