summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2023-07-16 02:00:00 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2023-07-16 02:00:00 +0200
commit800fef714c12768d54507870798e1f7850be2f0b (patch)
treea6a77026a684bcf35c0f9d50eb19a56f020ba1ea
parentd2ce2e0feefe3f1d7d400d9d825c0a11f5e395b6 (diff)
downloadguix-800fef714c12768d54507870798e1f7850be2f0b.tar.gz
gnu: xa: Use G-expressions.
* gnu/packages/assembly.scm (xa)[arguments]:
Rewrite as G-expressions.
-rw-r--r--gnu/packages/assembly.scm12
1 files changed, 7 insertions, 5 deletions
diff --git a/gnu/packages/assembly.scm b/gnu/packages/assembly.scm
index dbf52ed01b..9cbdb53328 100644
--- a/gnu/packages/assembly.scm
+++ b/gnu/packages/assembly.scm
@@ -405,11 +405,13 @@ Supported architectures are:
                 "0bph41aglxl07rnggrir2dl1x97f52hm0bl51d0vklyqvfyvm6qv"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:tests? #f   ; TODO: custom test harness, not sure how it works
-       #:phases
-       (modify-phases %standard-phases
-         (delete 'configure))            ; no "configure" script
-       #:make-flags (list (string-append "DESTDIR=" (assoc-ref %outputs "out")))))
+     (list
+      #:tests? #f           ; TODO: custom test harness, not sure how it works
+      #:phases
+      #~(modify-phases %standard-phases
+          (delete 'configure))          ; no "configure" script
+      #:make-flags
+      #~(list (string-append "DESTDIR=" #$output)))) ; no $prefix support
     (native-inputs (list perl))
     (home-page "https://www.floodgap.com/retrotech/xa/")
     (synopsis "Two-pass portable cross-assembler")