summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-04 21:43:12 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-11 12:18:33 -0500
commit82b10c93b8c01c0fa3f078dcf784f78222a67fe7 (patch)
tree44e79c8e9738aac88b89720db3373986ebf61b6e
parent33cdba945b1b5ecdd91417e2c090ef11797d37e1 (diff)
downloadguix-82b10c93b8c01c0fa3f078dcf784f78222a67fe7.tar.gz
gnu: Add python-asyncpg.
* gnu/packages/databases.scm (python-asyncpg): New variable.
-rw-r--r--gnu/packages/databases.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 9b35d0a31e..1546f822c8 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -2628,6 +2628,36 @@ for many database kinds that tortoise-orm doesn't need, for example.")
 coroutine-specific markup.")
     (license license:asl2.0)))
 
+(define-public python-asyncpg
+  (package
+    (name "python-asyncpg")
+    (version "0.24.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "asyncpg" version))
+       (sha256
+        (base32 "1in0q6iffpl8ag6ady4bvwnn40igh10cpp4xgm426j1lqdis0byx"))))
+    (build-system python-build-system)
+    (propagated-inputs (list python-typing-extensions))
+    (native-inputs
+     (list postgresql
+           python-cython
+           python-flake8
+           python-pycodestyle
+           python-pytest
+           python-sphinx
+           python-sphinx-rtd-theme
+           python-sphinxcontrib-asyncio
+           python-uvloop))
+    (home-page "https://github.com/MagicStack/asyncpg")
+    (synopsis "Fast PostgreSQL database client library for Python")
+    (description "@code{asyncpg} is a database interface library designed
+specifically for PostgreSQL and Python/asyncio.  @code{asyncpg} is an
+efficient, clean implementation of PostgreSQL server binary protocol for use
+with Python's asyncio framework.")
+    (license license:asl2.0)))
+
 (define-public python-tortoise-orm
   (package
     (name "python-tortoise-orm")