summary refs log tree commit diff
diff options
context:
space:
mode:
authorJanneke Nieuwenhuizen <janneke@gnu.org>2023-06-19 17:19:56 +0200
committerJanneke Nieuwenhuizen <janneke@gnu.org>2023-07-21 17:54:44 +0200
commit82bbb519a3b1b4d7c3ebee590475b28ca51f976a (patch)
tree4fcfd284b9ff62b6dee07c842847190812a0f792
parentf46fbd13e787702b164765efb6b086baf6d057be (diff)
downloadguix-82bbb519a3b1b4d7c3ebee590475b28ca51f976a.tar.gz
gnu: guix: Disable some tests on the Hurd.
* gnu/packages/package-management.scm (guix)[arguments]: When building on the
Hurd, add phase disable-tests/hurd.
-rw-r--r--gnu/packages/package-management.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index 367caf4d29..966940d4f4 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -273,6 +273,40 @@ $(prefix)/etc/openrc\n")))
                                   (("tests/guix-package.sh") "")
                                   (("tests/guix-system.sh") "")))))
                         '())
+                    ,@(if (system-hurd?)
+                          `((add-after 'unpack 'disable-tests/hurd
+                              (lambda _
+                                (substitute* "Makefile.am"
+                                  (("tests/derivations.scm") "")
+                                  (("tests/graph.scm") "")
+                                  (("tests/lint.scm") "")
+                                  (("tests/nar.scm") "")
+                                  (("tests/pack.scm") "")
+                                  (("tests/processes.scm") "")
+                                  (("tests/publish.scm") "")
+                                  (("tests/pypi.scm") "")
+                                  (("tests/size.scm") "")
+                                  (("tests/store.scm") "")
+                                  (("tests/substitute.scm") "")
+                                  (("tests/syscalls.scm") "")
+                                  (("tests/union.scm") "")
+                                  (("tests/guix-build-branch.sh") "")
+                                  (("tests/guix-hash.sh") "")
+                                  (("tests/guix-locate.sh") "")
+                                  (("tests/guix-pack.sh") "")
+                                  (("tests/guix-pack-relocatable.sh") "")
+                                  (("tests/guix-package-aliases.sh") "")
+                                  (("tests/guix-package-net.sh") "")
+                                  (("tests/guix-home.sh") "")
+                                  (("tests/guix-archive.sh") "")
+                                  (("tests/guix-environment.sh") "")
+                                  (("tests/guix-refresh.sh") "")
+                                  (("tests/guix-shell.sh") "")
+                                  (("tests/guix-shell-export-manifest.sh") "")
+                                  (("tests/guix-graph.sh") "")
+                                  (("tests/guix-gc.sh") "")
+                                  (("tests/guix-daemon.sh") "")))))
+                        '())
                     (add-before 'build 'use-host-compressors
                       (lambda* (#:key inputs target #:allow-other-keys)
                         (when target