summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-20 11:06:54 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-20 11:17:45 +0200
commit8a13eabf7db8be62d9b16608140427104320442b (patch)
tree1531a438c089c73bd324e4c8f026dfdca27ac650
parentfd1ac474b79cb458f51b461d896d0afd0b3f7860 (diff)
downloadguix-8a13eabf7db8be62d9b16608140427104320442b.tar.gz
gnu: Add texlive-tex-ps.
* gnu/packages/tex.scm (texlive-tex-ps): New variable.
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 284fd6c9d0..e305fc74ee 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3796,6 +3796,26 @@ Knuth's TeX book; this source is there to read, as an example of writing TeX ;
 it should not be processed without Knuth's direct permission.")
     (license license:knuth)))
 
+(define-public texlive-tex-ps
+  (package
+    (name "texlive-tex-ps")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/generic/tex-ps/cmyk-hax/"
+                   "doc/generic/tex-ps/poligraf/"
+                   "dvips/tex-ps/" "tex/generic/tex-ps/")
+             (base32
+              "09f70q2bhmq7bn98f2g2pq62wnfhj24bzkbv652sjrw5rafp0311")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/tex-ps")
+    (synopsis "TeX to PostScript generic macros and add-ons")
+    (description
+     "This package provides TeX to PostScript generic macros and add-ons:
+transformations of EPS files, prepress preparation, color separation, mirror,
+etc.")
+    (license license:public-domain)))
 
 (define-public texlive-lcdftypetools
   (package