summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-18 11:00:01 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:12:27 +0200
commit8b2d1a93475b64adb23ec49443476b3fd5fb629b (patch)
treeb07a540c88e40d61bef49bb3b6af40a79ff5a406
parent6a09a6c5eb570eca34818d95b069c082dce5ee4f (diff)
downloadguix-8b2d1a93475b64adb23ec49443476b3fd5fb629b.tar.gz
gnu: texlive-tetex: Refresh package definition.
* gnu/packages/tex.scm (texlive-tetex): Remove SIMPLE-TEXLIVE-PACKAGE
call.
-rw-r--r--gnu/packages/tex.scm26
1 files changed, 15 insertions, 11 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 50cde22825..dbbfcad9d8 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4288,19 +4288,23 @@ of file names.")
 
 (define-public texlive-tetex
   (package
-    (inherit (simple-texlive-package
-              "texlive-tetex"
-              (list "/dvips/tetex/"
-                    "/fonts/enc/dvips/tetex/"
-                    "/fonts/map/dvips/tetex/")
-              (base32
-               "05mf8yqdj2wrc1zm3al2j4aam2wx0ky6a7slxw17pkd1c7rmvjrq")
-              #:trivial? #t))
+    (name "texlive-tetex")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "dvips/tetex/"
+                   "fonts/enc/dvips/tetex/"
+                   "fonts/map/dvips/tetex/")
+             (base32
+              "05mf8yqdj2wrc1zm3al2j4aam2wx0ky6a7slxw17pkd1c7rmvjrq")))
+    (build-system texlive-build-system)
+    (arguments (list #:texlive-latex-base #f))
     (home-page "https://www.ctan.org/pkg/tetex")
     (synopsis "Font maps originally from teTeX")
-    (description "This package provides font maps that were originally part of
-the now obsolete teTeX distributions but are still used at the core of the TeX
-Live distribution.")
+    (description
+     "This package provides font maps that were originally part of the now
+obsolete teTeX distributions but are still used at the core of the TeX Live
+distribution.")
     (license license:public-domain)))
 
 (define-public texlive-l3kernel