summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-16 22:31:41 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:12:13 +0200
commit8ba050da8b0c690270666403333e7bdd764fe73c (patch)
tree2082b29b61d6500113f2e5bb4d949e6e09017568
parenta9fd178710614e46761c8a7547954345ca0d484d (diff)
downloadguix-8ba050da8b0c690270666403333e7bdd764fe73c.tar.gz
gnu: texlive-glyphlist: Refresh package definition.
* gnu/packages/tex.scm (texlive-glyphlist): Remove SIMPLE-TEXLIVE-PACKAGE
call.
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 11 insertions, 9 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 2d91577633..738307fafd 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3676,18 +3676,20 @@ the @file{.tex} extension.")
 
 (define-public texlive-glyphlist
   (package
-    (inherit (simple-texlive-package
-              "texlive-glyphlist"
-              (list "fonts/map/glyphlist/")
-              (base32
-               "12nmmyh77vr2622lzi11nm1z1k2bxs7jz018yl4rwjlpg0sxg1ja")
-              #:trivial? #t))
-    (home-page "https://www.tug.org/texlive/")
-    (synopsis "Adobe glyph list and TeX extensions")
+    (name "texlive-glyphlist")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "fonts/map/glyphlist/")
+             (base32
+              "12nmmyh77vr2622lzi11nm1z1k2bxs7jz018yl4rwjlpg0sxg1ja")))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/glyphlist")
+    (synopsis "Adobe Glyph List and TeX extensions")
     (description
      "This package provides a map between traditional Adobe glyph names and
 Unicode points; it is maintained by Adobe.  The additional
-@file{texglyphlist.txt} is maintained as part of lcdf-typetools.")
+@file{texglyphlist.txt} is maintained as part of @code{lcdf-typetools}.")
     (license license:asl2.0)))
 
 (define-public texlive-graphics-def