summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-28 00:07:48 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:12:47 +0200
commit8fe63131bab18099d54694233d0911e43ae241fa (patch)
treee1f79979aaf7616f6f208d1c61fd89d1517972a0
parent62fad0e46e6661b1336785069abea01651bbb35b (diff)
downloadguix-8fe63131bab18099d54694233d0911e43ae241fa.tar.gz
gnu: Add texlive-mfware.
* gnu/packages/tex.scm (texlive-mfware): New variable.
-rw-r--r--gnu/packages/tex.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index fc85896300..c67f109b34 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1563,6 +1563,36 @@ Taco Hoekwater.")
 
 (define-deprecated-package texlive-fonts-mflogo-font texlive-mflogo-font)
 
+(define-public texlive-mfware
+  (package
+    (name "texlive-mfware")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/man/man1/gftodvi.1"
+                   "doc/man/man1/gftodvi.man1.pdf"
+                   "doc/man/man1/gftopk.1"
+                   "doc/man/man1/gftopk.man1.pdf"
+                   "doc/man/man1/gftype.1"
+                   "doc/man/man1/gftype.man1.pdf"
+                   "doc/man/man1/mft.1"
+                   "doc/man/man1/mft.man1.pdf"
+                   "doc/man/man1/pktogf.1"
+                   "doc/man/man1/pktogf.man1.pdf"
+                   "doc/man/man1/pktype.1"
+                   "doc/man/man1/pktype.man1.pdf"
+                   "mft/base/")
+             (base32
+              "0v8i6w5kinh11xm0vmgb75sxb4lxznf3l1j78dq6xh55a79330ha")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/mfware")
+    (synopsis "Supporting tools for use with Metafont")
+    (description
+     "This package provides a collection of programs (as web source) for
+processing the output of Metafont.")
+    (license license:public-domain)))
+
 (define-public texlive-amsfonts
   (package
     (name "texlive-amsfonts")